Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The installation itself was giving an error: java.util.concurrent.ExecutionException: java.lang.RuntimeException: data starting at 0 is in unknown format

but when I deselected Aeromodeling toolbox then Matlab got successfully installed.

When I tried to run it I am getting this error:

Exception in thread "main" java.lang.NoClassDefFoundError: com/mathworks/instwiz/arch/ArchGuiFactory
Caused by: java.lang.ClassNotFoundException: com.mathworks.instwiz.arch.ArchGuiFactory
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at sun.misc.Launcher$ExtClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class: com.mathworks.activationclient.ActivationApplication.  Program will exit.

I have openJDK 1.7 and openJDK-devel 1.7 installed in 64bit FC17. I reinstalled openJDK but still the problem persists.

is there any extra dependency?? is there a problem of linking with java? How to solve this problem

share|improve this question
    
please let me know how to fix this.. the same version of Matlab works in my other system.. –  bharat_iyengar Apr 4 '13 at 6:21
    
Have you tried reinstalling MATLAB? Which error did you face when installing? –  Pincopallino Apr 4 '13 at 7:48
    
i tried reinstalling matlab.. the initial installation failed because of some dependencies of Aero toolbox.. this was the error java.util.concurrent.ExecutionException: java.lang.RuntimeException: data starting at 0 is in unknown format so without the aero toolbox it installed but wont load.. i am pretty convinced that there is a problem with loading jre.. no idea how to fix it –  bharat_iyengar Apr 4 '13 at 9:46
    
installation still fails when i select aero toolbox –  bharat_iyengar Apr 4 '13 at 9:59
    
The line Could not find the main class: com.mathworks.activationclient.ActivationApplication might indicate that you chose a wrong activation method? Anyway, you might have a look at this thread: forums.fedoraforum.org/showthread.php?t=284091 –  Pincopallino Apr 4 '13 at 10:39
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.