Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Built in PDF viewer in firefox is great. About 5% of PDF files viewed, a user may want to keep - however under a file name that is chosen/defined by him.

When in the viewer and clicking save - how can I achive FF to prompt me for save-as name? (or any work-around achieving this).

share|improve this question

3 Answers 3

The web application that delivers the PDF file to your browser can set HTTP headers for content-type and content-disposition. That's how the browser knows to treat it as a PDF file and pull up the viewer. It's also how the web application can send your browser a default filename that comes up when you do a Save As. That works better for attachment content-dispositions than for inline ones.

share|improve this answer
    
This explains how the file name is specified by the server, but not how to override it. –  Karan Apr 3 '13 at 16:24
    
True, the user has to pull up a Save As browser dialog. This just explains where the default filename in the dialog comes from. (For inline dispositions it defaults to the page name instead.) –  criticalfix Apr 3 '13 at 16:31
up vote 1 down vote accepted

The built-in viewer only has a download function and does not prompt to set the filename. However, it is still possible to do it via the Firefox menu. To specify the file name, use FileSave Page As... menu option.

share|improve this answer
    
It does prompt for the file name when you ask it to save. What version of Firefox are you using? –  Wk_of_Angmar Apr 8 '13 at 0:12

In the preferences dialog, General tab, under Downloads, select Always ask....

Screenshot of preferences | general tab

Edit: If this is too general, there is a similar option for each file type in the Applications tab:

screenshot of preferences | applications tab

share|improve this answer
    
The OP want to do it for PDF, but not for ZIP files or .EXE or .MSI files. So it is good, but not good enough to activate this option. –  user984532 Apr 4 '13 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.