Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Debian Sid on Thinkpad X61 has troubles reading from one of my USB flash drives (ADATA S102). Even accessing raw block storage is a problem:

liori:% LANG= dd if=/dev/sdb bs=512 count=1 | hexdump
dd: opening '/dev/sdb': No medium found

I get the same error when trying to mount it manually using either mount or udisks --mount. Dmesg does not report any errors (this is after trying to read from the drive):

[559579.972136] usb 2-2: new high-speed USB device number 22 using ehci_hcd
[559580.105313] usb 2-2: New USB device found, idVendor=125f, idProduct=312b
[559580.105324] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[559580.105332] usb 2-2: Product: ADATA USB Flash Drive
[559580.105339] usb 2-2: Manufacturer: ADATA
[559580.105346] usb 2-2: SerialNumber: 000000000000000302
[559580.106098] scsi27 : usb-storage 2-2:1.0
[559581.104896] scsi 27:0:0:0: Direct-Access     ADATA    NAND Flash       1.00 PQ: 0 ANSI: 6
[559581.106930] sd 27:0:0:0: Attached scsi generic sg2 type 0
[559581.108437] sd 27:0:0:0: [sdb] Attached SCSI removable disk

This drive used to work in the past. It was formatted to UDF according to these notes. I have another drive of the same exact model, and it works perfectly. I get the same results on another Thinkpad X61 with Ubuntu 12.04, and Thinkpad T43p with Windows 7 does not see the drive either (although it doesn't report any error message—or I don't know where to look for it).

The drive is USB3.0-capable, but I don't have any USB3.0 ports to check it if it would work there.

Any help making the drive work again is appreciated.

EDIT: The drive magically started working again, as if nothing happened. I'll leave the question opened just in case the problem comes back.

share|improve this question

2 Answers 2

If another drive of the same model works, it's likely that the faulty drive is corrupted in some way. Going by what you've put I'd say it was the formatting that caused the problem. Try re-formatting, and if it still doesn't work, just get a new flash drive.

share|improve this answer
The other drive is also formatted the same way. I cannot format the faulty drive at all, the system does not allow any access to raw block storage. – liori Apr 3 '13 at 16:46
When you formatted the now faulty drive, how long was it before it stopped working and what did you use it for in that period which might have caused it to stop working? – Ross Hunter Apr 3 '13 at 16:55
The drive was bought in early February. As far as I know, it was used to move several GB of data (I'm almost certain that not more than ~50) total in batches of maybe 5GB (video captures). It was used only in the three notebooks mentioned in the question, and it seems that it has not been used since early March (with no problems at the time). – liori Apr 3 '13 at 17:18
Well, there are so many things that could have happened to make it faulty, so I can't really identify the problem. If your devices can't pick it up, then you can't change it meaning there's really nothing you can do. The only thing that springs to mind is that you mentioned that is was a USB 3 memory stick. This is a long shot, but I've got a USB 3 flash drive which only works in USB 3 ports and not USB 2 ports. This could be the source of your problem as well, but most USB 3 sticks work in older ports, so I wouldn't hold your breathe. Sorry I couldn't be of more help. – Ross Hunter Apr 3 '13 at 17:27
No problem. I tend to solve most problems by myself, and the ones I cannot solve are usually very difficult anyway. Thank you for trying. – liori Apr 3 '13 at 18:05

I had same problem today. After all researches Nothing help.

"No medium found" everywhere (fdisk, cfdisk, dd, parted, etc.)

Device: Adata 32GB C902


Downloaded "Adata USB Recovery" From the site: Adata USB Recovery tool (I entered my serial number to download the correct software).

I executed the tool in Windows XP. It says some metadata including wrong device name starts with XXXXXXXX and continues with some name.

Important thing was this line of matadata:
Firmware Ver.N:NO FIRMWARE.

I updated the firmware through the tool and the flash drive was repaired.

I think it's a firmware problem at all. You can try to update your firmware to solve this. Check your vendor for a recovery tool or firmware updater to fix the problem.

share|improve this answer
Oh, interesting. I'll give it a try. – liori Sep 17 at 19:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.