Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 9, and recently I have a very strange error.

My number pad on my keyboard don't work. Its not hardware since I changed the keyboard and I still have the same problem.

share|improve this question
    
does the NumLock LED light up? does it work when numlock is on/off? – quack quixote Oct 20 '09 at 11:40
    
yes, the light was woeking. the problem was in the accepted answer – Gabriel Solomon Oct 20 '09 at 18:49
up vote 6 down vote accepted

It could be your mouse settings. Your keyboard is set to move the cursor with your number pad.

To Slove this issue

  1. Go to System > Preferences > Accessibility > Keyboard Accessibility
  2. Select [x] Enable keyboard accessibility features
  3. Go to the tab Mouse Keys and deselect [ ] Enable keyboard accessibility features.

similar to article: http://arcanecode.com/2007/04/25/ubuntu-704-and-virtual-pc-2007-mouse-issue-workaround-sort-of/

share|improve this answer
4  
thanks it worked :D ... only that in ubuntu 9 they are in System > Preferences > Keyboard > Mouse Keys – Gabriel Solomon Oct 20 '09 at 11:47
    
How can I do this in Ubuntu 12.10? – Ionică Bizău Apr 10 '13 at 4:57

Check if the mouse pointer moves, when you press 4 on the numeric pad? If so your keyboard are in the incredibly annoying mouse keys state.

[shift]+[num lock] dosen't work for me on ubuntu 14.10

  • Enter the system settings menu
  • select "accessibility"
  • Choose the last tab The top switch is "mouse keys" Switch it of!
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .