Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am disabling iptables on Oracle Linux 6 with these commands.

setenforce 0
service iptables stop
service ip6tables stop
chkconfig—level 123456 iptables off
chkconfig—level 123456 ip6tables off

Even after doing this on reload when i do the

service iptables status

i see iptables as enabled and it loads up all the information from the file

/etc/sysconfig/iptables.save 

but the strange thing is then if i use the command chkconfig i see the status as off for all run levels still the above command has enabled iptables.

chkconfig --list iptables
iptables        0:off   1:off   2:off   3:off   4:off   5:off   6:off

Let me know if you would have answer to any of these questions

Would it be ok to delete the iptables.save file completely. How should i disable iptables service across reboots. Is the network Manager causing iptables service to be started ? inspite of chkconfig saying its off still some service seems to be enabling it.

share|improve this question

I found your question on stack overflow, as I had the same problem. I just solved it and I might be able to help you:

I had installed the firewall CSF and completely disabled iptables. Yet iptables kept restarting for some reason. After a while I found that CSF restarted it after an ip-address (mine in this case) made too many connections. I was pinging the server from one ip address and after 3000 calls, or 5 minutes, the connection refused because iptables blocked my ip-address. I added the ip addresses to the "allow-list" of csf by using CSF -a 192.168.1.1 where 192.168.1.1 was my ip address...

Hope this helps you!

share|improve this answer
    
i checked up and i dont have any csf program installed neither anything similar to it. – Yatin Apr 10 '13 at 21:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .