Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I wanted to get back into a bit of XNA so I installed Visual Studio 2012 Express Desktop and Visual Studio C# 2010. I also installed the XNA framework (which needs Games for Windows on windows 8) and got it working with 2012 following these directions. I did the restarts whenever it told me. This is when it started to just hang on a black/blank screen (no cursor) right after the windows balls logo thing (spash screen - right before log in screen).

I did not think anything of it the first time and I went about doing a ccleaner run of files and a registry clean up (I did back up the registry). I also went through a windows update as per normal routine. Restarted again for the updates and noticed it hanged again.

I tried merging the registry from the ccleaner backup but it gave me a error accessing the registry. I WAS able to merge the registry today so all is good there.

I have also run through a Advanced Startup options Automatic repair but it said it was unable to repair.

I have uninstalled Visual Studio 2012, 2010, XNA, and Games for Windows and boot times still take 20 minutes. The computer seems to work fine once it is loaded up. Before I thought it could be Visual Studio or something I though Norton could be the culprit and it did give me a Error 8506, 421 so I uninstalled last night and reinstalled today.

My computer is a Asus K-Series Laptop (K55N more specifically K55N-RHA8N29).

What should I do to get my computer back to normal?

There is a similar issue here: Windows 8 stops booting after installation of Visual Studio 2012 Desktop

EDIT:

I did install Team Foundation Server which is Microsofts source Control but I could not get that to work and it crashed my Visual Studio when opening projects so I unintalled Team Foundation Server and Visual Studio 2012 and then reinstalled VS 2012. I got TortoiseSVN instead and set up the context menu commands.

Also taking a look at msconfig. On the startup selection it has Selective Startup with Load system services and load startup items checked (I did not change) Should it be Normal startup? -- Just read when you do the Advanced Troubleshoot (probably same as Advanced Startup options) it changes from normal to Selective. I have changed it to Normal but have not restarted to see results.

EDIT 2:

I just looked at the bios updates for my laptop and saw "Fix the bug that System will show black screen" so maybe I need to update my bios (unsure of current version). I am not sure how to update but going to research now. Unfortunately it looks like my bios is up to date. The download is for BIOS 217 and mine says 217. bios version

Edit 3:

After running xbootmgr (suggested by magicandre1981) I have a nice log file of what is going on. I wish I knew better how to analyze this data. From the log I have learned that the Winlogon Init Phase took 25 minutes. Please assist analyze this file better to get more information.

Here is a download of two traces I did: *removed

trace analyzer

Edit 4 (4/5 - 6:23pm):

I was going to try to delete the trouble font by hooking up the hdd to another PC but it was not recognized on a Windows XP machine with my sata-usb adapter. I put the hdd back and booted but the notebook and it went super fast like it used to. I turned it off and back on and it went back to being slow. Just thought I would share the glimmer of hope.

Edit 5 (4/5 - 8:21pm):

I finally got rid of that f.... pesky font. The font was Kozuka from Adobe for future reference and it took a lot of work to get rid of it. It's like the OS latched on to it and did not want to let go. I downloaded NexusFont and got rid of the general family of it but there were two files (KozMinPro-ExtraLight.otf, and KozMinPro-Regular.otf) that stuck around in the System Font folder only visible through the UNC path convention (\computer-name\c$\Windows\Fonts). Had to use a cmd command (rd /s c:\$Recycle.Bin) to empty the recycle bin and use a del command to finally get rid of the files. Boot times are down to about 7 minutes which is better but not back to normal.

Here is a couple traces from the 7 min boots: *removed

Clarification (8:47pm) - I shutdown and started up and it is going fast as normal now. Not saying it is solved but possibly. Traces are essentially restarts and still 7 minutes but without trace it takes about 3 minutes to restart (not sure how long when normal). Shutdown and Turn back on seem to work lickety split.

Edit 6 (4/6 12:03pm):

Good new, fast-boot trace and normal boot trace were fast as ever. I disabled Unlocker from startup and turned off the services for Spybot and Teamviewer. Wamp is the only NON-Microsoft service that isn't disabled (for some reason it does not re-enable the service when it starts up). I have not tried plain restart since last night.

Download both here: http://db.tt/Kw2HVBqi

share|improve this question
    
is your motherboard a Gigabyte brand board? Gigabyte has a knows usb3 driver issue. what is make and model. also check your startup tab and disable any visual studio item to start on boot up and see if that solves issue. any service not started on boot up will start when program is executed so it is ok to remove startup items (not to be confused with services). you can view startup items by clicking start, type msconfig into box and open it. click startup tab at top. also you can check the system event viewer for errors and more info. cant remember location im on linux at moment. –  user213584 Apr 4 '13 at 0:17
    
@sethbuffington My laptop is a Asus K55N-RHA8N29 (asus.com/Notebooks_Ultrabooks/K55N - Manual: dlcdnet.asus.com/pub/ASUS/nb/K55N/…). Not sure on the motherboard; it does have 2 USB 3.0 ports. I have not had any issue before yesterday and my Asus Updater says it has no updates. There isn't any start up items for Visual Studio. The SRT log file for automatic repair says everything completed succesfully. The System event log says there are 4 critical errors (in 24 hours) which the source is Kernel-Power. Check my edit on the OP as well. –  MLM Apr 4 '13 at 0:53
    
run xbootmgr to see what is slow when booting: msfn.org/board/index.php?showtopic=158252 –  magicandre1981 Apr 4 '13 at 3:57
    
@magicandre1981 Thanks for this enlightening program! Please help me look at it deeper. I added some basic info to the op. –  MLM Apr 4 '13 at 4:51
    
I need the ETL file to see what is slow. Zip and upload the file (skydrive, dropbox, google) and insert a link to your 1st post. –  magicandre1981 Apr 4 '13 at 5:05
show 2 more comments

1 Answer 1

up vote 3 down vote accepted

ok, I looked at the trace and found that the ProfileService takes 281s to start:

 <serviceTransition name="ProfSvc" group="ProfSvc_Group" transition="start" totalTransitionTimeDelta="281174"

I can also see that the HDD is busy loading the file C:\Windows\Fonts\KozMinPro-ExtraLight.otf This takes 312s and causes the WinLogon.exe slwdown. Remove this font and look if you get a faster boot. If not, provide a new trace.

share|improve this answer
    
That font is very odd. I am unable to delete that specific file because it says it is in use. Looking into a way to force delete or something. Also what can I do about the ProfileService? –  MLM Apr 4 '13 at 19:04
    
try to use Unlocker to delete the file. Let us fix this first, before looking at the other issue. –  magicandre1981 Apr 4 '13 at 19:38
    
I deleted it using a cmd thing I found. Also new trace in op. –  MLM Apr 4 '13 at 19:45
    
The last trace shows the file C:\Windows\Fonts\KozMinPro-ExtraLight.otf is still loaded slowly. Open control panel,go to installed fonts and uninstall the font properly. –  magicandre1981 Apr 4 '13 at 20:12
    
It is not in the list anymore but it may have had to restart to get rid of it. gyazo.com/b624848d5d9a01370a93f93dad2d4429 –  MLM Apr 4 '13 at 20:18
show 12 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.