Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my videos on a Windows Home Server. I have access to the shared folders, i.e. \\server\movies, with modify permissions.

When I try to delete a folder like \\server\movies\movie, other files get deleted, but I usually get this error at thumbs.db.

The action can't be completed because the file is open in Windows Explorer

It happens even if I try to delete the folder without even opening it (just right-clicking on it). I am always able to delete the folder by logging into the server.

I imagine my PC forces the thumbnail files to be created when I open the folder to play a movie (I almost never login to the server). If I look at the permissions for the file, I see that the owner is the Administrators group on the server.

What should I do in order to be able to completely delete these folders, but from my client PC?

share|improve this question
    
Interesting, have you validated the permissions on the share itself? Normally these should inherit on create once you've assigned them, is it possible that you've got an ACL configured differently on that box for particular folders? If the directory isn't terribly large I'd recommend removing the share and running the wizard again to reapply the permissions and see if you continue to see the issue. –  aolszowka Dec 7 '13 at 2:13

1 Answer 1

This is happening because you're opening the remote folder to view its contents before you delete it (naturally, since you want to make sure there's nothing in it you wish to keep). However, this is causing Windows to update the thumbs.db Thumbnail cache.

There are a few ways to address this:

  1. Don't open the folder before deleting it
  2. Wait 30-60 seconds after opening the folder before deleting it. This gives Windows time to close the thumbs.db file
  3. From your file server, use the Shares snap-in to close the file handle for thumbs.db held open by your workstation (requires advanced knowledge, but an option nonetheless)
  4. Prevent Windows from creating the thumbs.db in the first place by disabling it in Folder Options:
    • Open Windows Explorer
    • On the Tools menu click Folder Options (in Windows 7/8 tap Alt to reveal the Menu bar)
    • On the View tab enable Always show icons, never thumbnails (In Windows XP the option is Do not cache thumbnails):
      enter image description here
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.