Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can visit any website except for Google.com just fine. Other browsers pull up Google just fine. Only Chrome has the issue. Once I clear the cache it will work again just fine. But I must clear the cache every time I open the application or else it will not work. What might have caused this to all of a sudden become a problem (and continue to be one)?

MBP 2.66 GHz Intel Core i7 w/8GB RAM running OS X 10.8.3. Chrome Version 26.0.1410.43 (up to date). I've already tried rebooting and checking for physical disk corruption. Those are not the issues.

share|improve this question
    
Use the google address without 's' in http address ! like this : "h t t p://www.google.com" instead of this "h t t p s ://www.google.com" without space. maybe you use the old version of chrome?! –  Sam Apr 4 '13 at 6:40
    
Using http (non-SSL) results in the same issues. –  Daи Apr 4 '13 at 13:42

1 Answer 1

Chrome has some problems with HTTPS since a week or so. It doesn't happen on all machines and may also depend on the network connection you use (i.e. it may sometimes work on some public Wi-Fi networks). All we can do now is wait for a patch.

As a workaround you can try:

  • Clicking the address bar and pressing Enter, it's not the same as refreshing and may sometimes work.
  • Removing s from https in the address bar. But keep in mind that when browsing through HTTP your searches may be captured and viewed by other people using the same network.
share|improve this answer
    
I find it hard to believe that Chrome has a problem with secure http connections. Its much more likely this is an internet provider problem. –  Ramhound Apr 4 '13 at 11:28
    
I've also tried different providers (mentioned public hotspot) and failed sometimes too. It doesn't happen every time and is sometimes fixed (or broken) by restarting Chrome, other browsers work just fine. Problem affects only Google sites (search, Reader, Gmail etc.) I think it's not a problem with Chrome itself, but rather with the SPDY protocol. That would explain why only Google sites don't work. –  gronostaj Apr 4 '13 at 12:25
    
It could be a problem with SPDY I suppose although its very unlikely. –  Ramhound Apr 4 '13 at 13:05
    
@Ramhound it's not an ISP issue. I can access Google via HTTPS and HTTP using any other browser. This only happens in Chrome. –  Daи Apr 4 '13 at 13:41
    
Then it must be a configuration problem considering I have no problem visiting any of Google's secure websites. Infact I force https to be used if its offered. –  Ramhound Apr 4 '13 at 13:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.