Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't open links from skype and other programs with my Google Chrome, I have it set as default browser throught my preferences in Google Chrome, but when I checked my Default Programs in my control panel I couldn't even find Google Chrome listed!

What can I do to "add" chrome to the list of default programs? It wasnt listed here either "Set Associations" under the HTTP and HTTPS, it just said "Chrome HTML document, Unknown Program".

share|improve this question
    
get the latest version of chrome and re-install it !!! – Sam Apr 4 '13 at 11:59
    
I installed chrome last week (the latest version) and the links haven't been working from the beginning. – Klint550 Apr 4 '13 at 13:44

Default Program Editor is a great program that can help you set the default programs in Windows. It is portable so no need to install anything. http://defaultprogramseditor.com/

share|improve this answer

We have to set it from within Google Chrome to make it the default browser.

In Chrome browser, go to setting , then click the button that says "make Google Chrome the default Browser for this computer".

Hope this helps!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .