Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been struggling with Xming and putty for a while and I can't make it work; I enabled X11 forwarding in putty, updated xauth list on the client side with the xauth list of the server side.

Currently I can run xclock from the client machine on the server machine when the DISPLAY is set to :0.0 (it shows xclock on the server machine), but I can't run it locally on the client machine; in other words, xming window doesn't pop up at all.

I already changed the DISPLAY to localhost:0.0, myip:0.0, and none has worked. When I run xclock (when display is set to myip:0.0) it starts (I don't get "can't find Display" error) but still xming doesn't show anything.

P.S. In my sshd_config I have the following lines:

X11Forwarding yes X11Displayoffset 10 X11UseLocalhost yes

share|improve this question
add comment

1 Answer

Try this:

  • First, unset any DISPLAY variable, as this will make puTTY take that value as it's target display.
  • Execute XLaunch (bundled with the Xming installer) with the default display (:0.0)
  • Next, launch puTTY as:

    putty -X {user}@{host}

    replacing {user} and {host} with your username and the hostname or ip address of your remote computer

  • Launch xeyes or any other x application in the puTTY console.

When you use puTTY with -X flag, it automatically creates a bridge between a local display in the remote computer, and the :0.0 display in the local one. You can also use -X <display> to user a non-default local display.

The -X flag can also be set in the configuration window of puTTY under the section: Connection -> SSH -> X11 -> Enable X11 Forwarding

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.