Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The issue:

VMware Fusion cannot connect to the virtual machine.

Make sure you have rights to run the program and to access all directories it uses and rights to access all directories for temporary files.

I have followed the instructions at the following 2 web sites and neither have worked:

Using terminal with the following command : kextstat | grep vmware

120 0 0x5ca93000 0xd3000 0xd2000 com.vmware.kext.vmx86 (2.0.6) <11 5 4 3 1>
121 0 0x5c3cc000 0xb000 0xa000 com.vmware.kext.vmci (2.0.6) <5 4 3 1>
122 0 0x5c3d7000 0x6000 0x5000 com.vmware.kext.vmioplug (2.0.6) <34 29 5 4 3>
123 0 0x5c413000 0x9000 0x8000 com.vmware.kext.vmnet (2.0.6) <11 5 4 3 1>

I have used Disk Utility to check permissions and verify the disk and all checks out OK.

There have been no changes to the system, no new software, no config changes, etc. Just one day it works the next it doesn't.

share|improve this question
    
Enabling the root user allows me to access the virtual machines again. So this is clearly a permissions issue, but what specific vmware fusion files do I need to change to restore permissions? –  ricbax Oct 22 '09 at 0:37

6 Answers 6

up vote 1 down vote accepted

I have finally figured out what the issue was and it actually relates somewhat to one of my questions at SO, http://stackoverflow.com/questions/1352899/source-install-apache-2-2-13-php-5-3-snow-leopard which ironically I also had to answer for myself.

The issue stemmed from the package iconv. Apparently compiling and installing PHP 5.3.0 has issues on Snow Leopard 10.6.1 with this package. So I deleted all occurrences of files that relate to this package from my system and rebuilt them from source in both i386 and x86_64 architectures. Unfortunately I deleted a very important file that VMWare Fusion required: /usr/lib/libiconv.2.dylib

The way that I realized that this file was the key to restoring VMWare Fusion was that I ran the following in terminal: /Applications/VMware\ Fusion.app/Contents/MacOS/vmware and said that the Following Resource was missing: /usr/lib/libiconv.2.dylib

So I went hunting in TimeMachine and luckily located the deleted file, restored it, and now all my VMs work again!

The question now is why is this file so important?

share|improve this answer
    
ricbax on cars: "Why is this wheel so important?" –  ta.speot.is May 3 '11 at 8:38
    
taspeotis on wheels: "Because they make the car move forward" –  ricbax May 12 '11 at 2:26

Have you checked the permissions of the actual Virtual Machine folder and it's contents? If you don't have write access to the Virtual Machine, VMware can throw a wobbly.

Disk Utility's Check Permissions won't check the permissions of your Virtual Machine.

Do you use the Virtual Machine under one user or different users?

(We have some VMs at work that can be shared by different Mac users, and we set the permissions to 777. I'd rather use ACLs - 777 is a bit extreme, but it works!)

share|improve this answer
    
Do permissions change automagically? I haven't changed any permissions on my MBP. So you are say I should chmod 777 the Virtual Machines folder? –  ricbax Oct 21 '09 at 0:51
    
Changed permissions to 777, the vm is used by the user of the MBP and I am the only user. I still get the error. –  ricbax Oct 21 '09 at 1:52

Permissions is a good idea...

But I have seen this behavior with Parallels as well... Throw out the old VMWARE fusion application, and re-install from the latest disk image from the VMWare site....

Re-installing with the application in place doesn't guarantee that everything will be re-written...

share|improve this answer

My problem was that I had to many threads running, even a simple command such as ls gave me:

fork: Resource temporarily unavailable

I stopped Firefox and it worked fine again.

share|improve this answer

I suspect that the setuid bit has been lost from one or more of the helper apps (most likely the vmware-vmx application). The helper programs are in /Library/Application Support/VMware Fusion and must have the setuid bit set.

Run the following command from a Terminal window and look at the permission bits for: vmware-authd, vmware-rawdiskCreator, vmware-vmx, vmware-vmx-debug:

ls -l /Library/Application Support/VMware\ Fusion

The permission bits should be:

-rwsr-xr-x  1 root wheel  <size> <date> <name>

ie. setuid root (the s in -rwsr-xr-x). You can either use:

sudo chmod +s /Library/Application Support/VMware\ Fusion/<name of app that's wrong>

If the user name isn't root then you should also do:

sudo chown root /Library/Application Support/VMware\ Fusion/<name of app that's wrong>

Alternatively, uninstalling and reinstalling the application should achieve the same thing.

share|improve this answer
    
Thanks for the response Andrew, but all the settings you mention here are set exactly as you mention them. uninstall/reinstall does nothing. –  ricbax Oct 23 '09 at 18:11

Yes it's a permision thing, but so what? I don't understand this discussion.

Uninstall (you'll find the VMware Uninstaller in the Library/Application Support) and then install VMware Fusion including any updates offered.

Open your virtual machines - they should be back again as they were and the problem will be solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.