Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got my friend's laptop that had a few problems. My friend didn't bother to get it repaired at the time and got himself a better machine.
As I've never been a "laptop" man I never even considered buying one but as this one was offered to me for free I was more than lucky to accept it.

The problem was that it's GPU was losing connection with the motherboard. I figured it out fairly quickly as the first results on google suggested this to be the problem and when I opened the laptop up and applied some pressure to the GPU when it was turned on the problem disappeared (The machine froze and screen got dark. I could see a dim picture but that was about it).

Still not willing to spend any money on the laptop to fix it I used a small, bent piece of paper on the top of the GPU (Please, don't criticise my fix and decision to do this. I know it's bad) to apply pressure to it, it worked but after turning on the computer I realised that the U, I, O & P keys on the keyboard are not working.

I googled the problem, many people have it, most common problem is numlock being turned on but it doesn't seem to be the problem here as I tried turning it off in many different ways with no luck.

It shouldn't be something caused by static as I wore a anti static bracelet. So... I'm pretty stumped here.
I'm currently stuck clueless at the bios password screen as I cannot press 2 of the letters in the password.

Note: I tried removing and replacing everything.

Update

I just got my hands on an USB keyboard and it works. I'm guessing I've somehow damaged the keyboard or the motherboard. Is there a way to test the cause of the problem (whether it's the keyboard or the motherboard) ?

share|improve this question
    
Did you check every key on the keyboard? What if a Key is stuck on, and that is why these keys do not function? –  Psycogeek Apr 4 '13 at 19:24
    
Yes, I checked other keys. All the other ones are working (They are inputting something at the password prompt). What makes me think is that UIOP keys are right next to each other. –  Pankucins Apr 4 '13 at 19:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.