Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to stream a live feed through RTSP to Windows Media Player 12 and get the error:

"Windows Media Player cannot play the file because the specified protocol is not supported. If you typed a URL in the Open URL dialog box, try using a different transport protocol (for example, "http:" or "rtsp:")."

  • I have tried the feed with both MPEG4 and MJPEG, but WMP doesn't work with either one of them, but I can get the feed with VLC just fine.

  • I have read this Knowledge Base document and tried the resolutions suggested and they have not worked.

  • I have removed WMP through Turn Windows Features On and Off and then manually deleted WMP from Program Files and also the files in the User directory. Yes, I reboot after turning off WMP.

  • I have turned off the Firewall in an attempt to verify that it is not blocking ports (you would think it would not be blocking ports since I can get the feed through VLC, but I tried it just in case).

  • I have also reduced my IE security settings to the lowest settings to see if it was a settings issue. Still got the error.

  • I do not have McAffee (others have suggested that this might cause some issues with streaming).

  • I am running Windows 7 x64 Professional. Other computers using Windows 7 x64 Pro can get the RTSP stream from Windows Media Player 12 (I have verified that they have the same build of WMP that I do).

  • I have compared registry settings between those computers that work and mine for Windows Media Player with no success.

  • I have tried to connect to different RTSP feeds from different encoder/decoders that I have and I get the same error as stated above, but again I can get the feeds with VLC.

(Yes, I know, why try to use Windows Media Player if VLC works? The answer is VLC doesn't work consistently, (drops ack signals and feed is lost), and I was trying to use a standard media player as a replacement.)

So the questions are: Why does my Windows Media Player 12 not recognize the RTSP protocol? And, how can I fix it so that it does?

share|improve this question

migrated from avp.stackexchange.com Apr 4 '13 at 23:39

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

    
Is it possible that the working Windows 7 systems have codecs installed that aren't present on your system, or vice versa? Most installed codecs should be listed in Control Panel - Programs. –  Tim De Baets Apr 6 '13 at 14:49
    
Yes, I thought of that, but forgot to mention that I have also installed K-Lite mega pack for both 32-bit and 64-bit and still got the same error. (Someone had suggested to do both depending on the bit of the player.) –  Fred Apr 8 '13 at 13:45
    
Installing the K-Lite codec pack definitely isn't recommended - you're likely just making the problem worse. Also, did you check for other codec differences between the systems? –  Tim De Baets Apr 8 '13 at 19:25
    
I haven't checked for exact codec differences, but I have checked for codec packages that have been installed. I can look into the exact codec differences. Why would K-Lite make things worse? –  Fred Apr 9 '13 at 17:23
    
Please do check for exact codec differences as well. As for K-Lite, see howtogeek.com/wiki/Why_Codec_Packs_Are_Bad –  Tim De Baets Apr 10 '13 at 18:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.