Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two network interfaces on my linux system. When I select eth0 as default gateway , everything works fine. I can connect to the system from other computers, but when I select eth1 as default gateway. Host is not reachable at all.

How can I diagnose this issue ? Below is ifconfig output when I select eth1 as default gateway

enter image description here

enter image description here

share|improve this question
    
We're going to need a LOT more information. Routes, network setup, etc. –  jnovack Apr 5 '13 at 13:48
    
@jnovack I have attached the output of route and network file. What do you meant network setup? –  Sirish Kumar Apr 5 '13 at 13:57
    
Is eth0 your public internet connection and eth1 your private intranet? Is this a linux router? –  jnovack Apr 5 '13 at 14:01
    
@jnovack eth0 is our intranet and eth1 is connected to a router in a different network. I am connecting from our intranet when eth0 is default gateway , it works may be because of this reason. I am not sure whether our intranet and network configured on eht1 can talk to each other(This is remote machine configured by my admin). I need to check this with admin. But wont I be able to connect to eth0 IP, since we are in same network? –  Sirish Kumar Apr 5 '13 at 14:18
    
There you go, answered your own question. It is impossible to tell if this will work unless your admin has made the 192.168. network talk to the 9.5. network. –  jnovack Apr 5 '13 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.