Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Kubuntu and I work on website development.

Then I work with file Html and I want open this file with Kwrite.

Kwrite is an editor and now I always (with two click on this) with Rekonq (browser's kubuntu)

If I change the open's remember application association for this type of file:

I do it in 3 steps:

  1. I right click on the file and choose Open With->Other... from the menu that appears. A list of applications appears.

  2. I Select the default application Kwrite.

  3. I Select the Remember application association for this type of file checkbox.

But this does not work.

share|improve this question

Try running mimeopen followed by the extension you want to change (in this case.html):

mimeopen .html  

You will get something similar to this:

Please choose a default application for files of type text/html

    1) winebrowser  (wine-extension-htm)
    2) Chromium Web Browser  (chromium-browser)
    3) Google Chrome  (google-chrome)
    4) Firefox Web Browser  (firefox)
    5) Geany  (geany)
    6) notepad  (wine-extension-txt)
    7) gedit  (gedit)
    8) LibreOffice 4.0 Writer  (libreoffice4.0-writer)
    9) Other...

use application #  

Enter the last number in the list (the one next to Other..., in this case 9) and press enter. When you get the prompt:

Use command:  

Enter /usr/bin/kwrite and press enter.

All .html files should now open in Kwrite.

share|improve this answer
    
This not function because not exchange in all file – Mirko Cianfarani Apr 7 '13 at 21:24
    
@MirkoCianfarani I don't really understand what you mean by that.. What "function" are you referring to? – Seth Apr 8 '13 at 15:06
    
That I want to configure the open all file *.html with Kwrite. I changed Mimeopen and the list of applications that can open this file type. But more (again ) when I open the file (for example) index.html . This is opened with Rekonq and not with Kwrite – Mirko Cianfarani Apr 8 '13 at 22:24
  1. Right click the file type you wish to associate with kwrite
  2. enter the file properties
  3. under the general tab click "file type options"
  4. now you will see a list of applications that can open this file type
    • move each one up or down depending on your personal preference.

(please note, i use KDE - this answer works!)

share|improve this answer
    
Sorry I delete Rekonq on the applications(4) but I have the problem... This not function.... – Mirko Cianfarani Apr 6 '13 at 11:01
    
use dolphin to find the file – dashboard Apr 6 '13 at 16:19
    
I always use Dolphin!!!! – Mirko Cianfarani Apr 6 '13 at 18:40
    
That I want to configure the open all file *.html with Kwrite. I changed Mimeopen and the list of applications that can open this file type. But more (again ) when I open the file (for example) index.html . This is opened with Rekonq and not with Kwrite – Mirko Cianfarani Apr 8 '13 at 22:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .