Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a Linux machine with Ubuntu 12.04 Precise. My problem is that whenever I restart my machine, it will not select the OS automatically and starts the boot process, instead I have to press the enter to select the OS and to start the boot process.

Problem arises when I try to ssh to this machine from remote location and tries to reboot. It will get rebooted but won't start up, so I cannot log-in to it remotely. I have to manually press enter button to start the boot process.

I have tried re-installing the OS, but it wouldn't help. I tried changing the /boot/grub/grub.cfg file settings but I won't be able to understand its default settings.

Please help.

share|improve this question

The default entry is determined by the GRUB_DEFAULT= setting in /etc/default/grub; the first "menuentry" has a value of "0".

Also, check the GRUB_TIMEOUT= setting.

Canonical has a great tutorial on Grub2 here: https://help.ubuntu.com/community/Grub2

share|improve this answer

In your grub configuration file you have to determine the entry number that should boot by default. This is done with the GRUB_DEFAULT variable:

GRUB_DEFAULT=0

This example would boot the first entry.

GRUB_DEFAULT=1

This example boots the second entry...

You can probably find this variable in your configuration file already (maybe it is commented out with a #), otherwise just place it there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .