Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to configure a freshly installed mysql server to listen on port 3306.

I've removed skip_networking, I have bind-address=127.0.0.1 and it completely ignores the config...

When I try SHOW VARIABLES LIKE 'skip_networking' I see it's still frustratingly ON.

netstat -na | grep mysql indicates it's listening on a random port, and yes, I do have port=3306 configured... Exact line is: unix 2 [ ACC ] STREAM LISTENING 45816 /var/run/mysqld/mysq d.sock

Running on Ubuntu 12.04.2

Am I missing something REALLY obvious?

share|improve this question
    
Are you certain you are editing the correct config file? This has bitten me maaaaany times. –  BrianAdkins Apr 5 '13 at 21:42
add comment

2 Answers

Disable skip-networking from:

/opt/local/etc/mysql55/macports-default.cnf
share|improve this answer
add comment

The issue stems from your use of netstat. The clue is that your sample output starts with "unix" instead of "tcp" (i.e., it's a Unix socket, vice a network port). Instead of "netstat -an", try "netstat -antup" and grep for "mysql" or "LISTEN".

In other words, MySQL is no longer listening on a network port. What you're seeing is a Unix socket, which isn't accessible from the network. (Hope this helps.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.