Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm writing to figure out why an SSH server on a rig isn't allowing tunneling. This is the sshd_config, looked perfectly fine to me.

# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

PermitTunnel yes
PermitOpen localhost:324
GatewayPorts yes
AllowTcpForwarding yes

When running sudo netstat -lptu, my port doesn't come up as listening. What am I doing wrong?

share|improve this question
    
Have you verified that the key files actually exist? –  kmort Apr 5 '13 at 22:54
    
authorized_keys? Yes they're there. –  Dboy1612 Apr 5 '13 at 23:18
    
How are you trying to set up the tunnel –  ekaj Apr 6 '13 at 1:08
    
I'm using Putty, Dynamic and Auto for port 324 and tried 9998. –  Dboy1612 Apr 6 '13 at 1:17

2 Answers 2

up vote 0 down vote accepted

Sorry, I jumped to the wrong conclusion in my other answer.

Here's a question addressing what the PuTTY Local, Remote, and Dynamic options are:

http://serverfault.com/questions/272754/what-is-the-difference-between-local-remote-dynamic-ssh-tunneling

Dynamic means opening a local port and acting as a SOCKS proxy for various connections out through whatever ports on the remote host.

If you want to open a port on the remote host to forward things back through the client, you'll need to use the Remote option with an appropriate destination.

share|improve this answer

You're trying to open a port <1024 as a non-root user. If you log in to your SSH session as root, I'd expect it to work.

share|improve this answer
    
I've tried ports higher and lower than 1024, and I'm in as root all the time. Still no luck. –  Dboy1612 Apr 6 '13 at 1:11
    
If you're in as root, why do you have to sudo your netstat? –  Jason Sherman Apr 6 '13 at 1:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.