Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying for about a week now to activate .Net Framework 3.5 on my computer to no avail. I've been trying to activate it via 'Turn Windows Features On and Off' in the control panel as well as separate downloads, including one that was supposed to have all the .Net 3.5 files downloaded with it. I keep getting error code 0x800F0922. My computer came pre-installed with Windows 8 and all I received with it is a Windows 8 Restore disc (Which I don't believe contains 3.5 anyways) with which I have tried running DISM with for sources/sxs several times The progress fills to 100%, hangs there for a minute or two and then returns with 'No operation was completed' or some such. I get the exact same error as well.

Here is a link to my CBS logs. One thing somebody else who was helping me pointed out was that the logs say I do not have presentationhost.exe, despite there being a copy of it and an accompanying .dll in System32 and SysWOW64. There are also a lot of errors for 0x80004005, which means I do not have the proper access to such files. I am an administrator and the only user on my system. On a related note, I cannot seem to do anything involving user accounts in my control panel. Trying to manage accounts, change account type or name and trying to change UAC settings does not do anything more than move my control panel to the background.

share|improve this question
    
I've never heard of CBS. Can you post your dism log somewhere? If you elevate %SystemRoot%\windows\system32\cmd.exe and run dism.exe /online /enable-feature /featurename:NetFX3 /all what error message does it give you? Also what does ver return? (The only acceptable answer is Microsoft Windows [Version 6.2.9200]) –  Mark Allen Apr 6 '13 at 2:57
    
Also from a command prompt, run net localgroup administrators - do you see your account listed there? –  Mark Allen Apr 6 '13 at 2:58
    
Ok, this is what a CBS log is. support.microsoft.com/kb/928228 Weird - part of my job involves the automation of installing .NET 3.5 and I'd never needed to look at that before. I could go on and on about automation systems that launch install steps in 32-bit environments on a 64-bit OS, but it's not relevant to your problem. –  Mark Allen Apr 6 '13 at 3:03
    
you already asked this on Technet Forum. Installing the WPF font cache service fails. –  magicandre1981 Apr 6 '13 at 6:24
    
@magicandre1981 Right, and no one could find a proper solution except for refresh and/or reset and hope it fixes it. I would like to exhaust as many options as possible before having to do either of those. –  Jokaste Apr 6 '13 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.