Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with multiple network cameras connecting via Wi-Fi to the same AP. I have an AP (TP-Link WA901N for now. I have tried others with same error.) and two cameras currently.

One is indoors near the AP, the other is outside in my yard. Both when connected to the AP individually report low latency (2-20 ms) with 0% packet-loss. Even while viewing the cam.

The minute I connect both devices simultaneously to the AP, packet loss and latency increases highly shortly after. (500-600ms, 2-30% PL). At first I thought this was due to my old AP not supporting MIMO but this unit does.

Attempting to negotiate another wireless client onto the same AP also has latency on that client. Disabling and enabling WMM has proven to not be effective at all.

Moving the indoor cam to another AP in the house alleviates this for now, but I would like to be able to support multiple cams on that same AP. Bandwidth used from both cams simultaneously is likely 2-3 megabit or so nothing crazy.

What can cause this behavior with multiple APs, etc? I have a feeling it may have to do with signal strength (No way to tell with this firmware on this.) but using my laptop in the same spot as the outside cam gets me over 25 snr so I'm not sure.

Is there anything I can do to mitigate this from occurring?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You don't mention a number of factors (for instance, the camera specs - 802.11g or 802.11n, how many antennas/radio chains, how many spatial streams, etc), however there are two things I would look at for this problem initially.

First, is that you could be running into the a hidden node problem. This would be a situation where the two cameras can both see the AP, but can't see each other. In this type of situation, since they can't see each other, they often "interrupt" each other causing data to be lost and retransmitted.

You can test this by bringing the three devices into the same room, or at least the two cameras. The intent is to make sure the cameras can easily see each other, and if this improves the situation, you may need to enable RTS/CTS if the cameras and AP support it.

RTS/CTS brings up the second likely problem, and that is there is a protection mechanism running in your wireless environment. RTS/CTS and CTS-to-self are two common protection methods to protect your higher speed devices from being "interrupted" by lower speed devices (namely 802.11b).

Since these are transmitted at the lowest base data rate (often 1Mbps) before each frame (or block of frames), this can impact performance significantly. If it isn't a hidden node problem, then try disabling 802.11b (if you have control of data rates, disable 1, 2, 5.5 and 11) and protection mechanisms on the AP if you have the option.

share|improve this answer
    
Sorry for lacking some information. Both cameras are 802.11g. AP has 3 antenna, single radio. I've never seen a hidden node issue like you mention, but it would make sense in theory if that's how the spec works for 802.11. I'll research and test that way. I can confirm wireless devices within the same room don't clobber the AP, only when I try to connect my outdoor one to my AP in the window. I suppose an easy way to test this theory would be to take as you said both cams and put them in the same room as the AP and test. And then ,take them both in the yard and test. –  Terry Zink Apr 6 '13 at 16:45
    
You can find information on the hidden node problem in many places. wifi.cs.st-andrews.ac.uk/wifihiddennode.html has a decent, simple explanation. However, now that we also know the cameras are 802.11g, then you may have airtime/throughput issues as well, as Havenard point out. In the best case, if you get actual throughput of 20+ Mbps with 802.11g, you are doing well. Since one of the cameras is fairly distant from the AP, it will be running a much reduced data rate, bring this number down significantly. You may need to look more at channel planning and reducing interference. –  YLearn Apr 6 '13 at 20:20
    
Thanks for the info. Very useful read. Did some experimenting before I went unhooking cameras. I forced my AP covering that ssid to be G only. Both are connected to it properly now. Hoorah. Such a stupid thing, I never thought it was downgrading the link to B. Waiting a day to say "huge success" but so far so good. Thanks again! –  Terry Zink Apr 7 '13 at 0:47

Check if there are more networks on the same channel, try moving to another channel just to see what happens. Playing with the network maximum speed and network mode (B, G, B+G etc.) can also be surprisingly effective in this matter.

High latency is pretty common in Wireless networks, the 2.4GHz band is widely used and its highly susceptible to interferance by other devices.

They even have a Wikipedia article about it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.