Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently I'm trying to install the YouCompleteMe extension to my vim setup, but it requires my vim to have the version of 7.3.584 or higher. The vim shipped with my Ubuntu 12.10 is 7.3.547, so I had to recompile vim from source following this instrucion.

As the instruction says, I executed:

sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev \
libgtk2.0-dev libatk1.0-dev libbonoboui2-dev \
libcairo2-dev libx11-dev libxpm-dev libxt-dev python-dev ruby-dev mercurial

which should give me all the packages needed for the compilation. However, when I've cloned the vim source and just about to start tweak the configuration for compilation, I got

checking for tgetent in -lcurses... yes
termcap library is not usable
no terminal library found
checking for tgetent()... configure: error: NOT FOUND!
    You need to install a terminal library; for example ncurses.
    Or specify the name of the library with --with-tlib.

I did some research, and got the general sense that I should specify ncurses as my terminal library. But when I did

./configure --with-tlib=ncurses

it yells back

checking --with-tlib argument... ncurses
chekcing for linking with ncurses library... OK
chekcing for tgetent()... configure: error: NOT FOUND!
    You need to install a terminal library; for example ncurses.
    Or specify the name of the library with --with-tlib.

I don't know if there is anything I've been missing, or if there is another way to get the newest version of vim? Many thanks!

share|improve this question
The error basically says you need the ncurses dev packages. Which is called "libncurses5-dev - developer's libraries for ncurses". – Shiki Apr 6 '13 at 15:38
@Shiki That I did install, per the instruction listed above :/ – alxyzc Apr 6 '13 at 15:45
Whoops. Sorry.. – Shiki Apr 7 '13 at 16:08
up vote 1 down vote accepted

I've been using that guy's PPA to keep Vim up-to-date on Ubuntu 11.04. The latest version is 7.3.854 which, I believe, works with YouCompleteMe.

share|improve this answer
Worked like a charm! Now the version's up. Thanks! – alxyzc Apr 6 '13 at 18:14
@alxyzc - This is why you should create a PPA on Launchpad, and copy there your fav packages. – Shiki Apr 7 '13 at 16:08
@Shiki Fully noted :) – alxyzc Apr 8 '13 at 8:31

On Ubuntu (and other Debian-based distos) you can get all required prerequisites with:

$ sudo apt-get build-dep vim-gnome

I don't know if that fixes the dependency problem, but it's worth a try.

share|improve this answer
Thanks for the advice, but when I did this, Picking 'vim' as source package instead of 'vim-gnome' Looks like it didn't work for me. – alxyzc Apr 6 '13 at 15:36

I had the exact same issue (recompiling vim to use YCM), and I fixed it by removing src/auto/config.cache (in the vim tree) and re-running ./configure. It seems an outdated configure cache was still there.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.