Currently I'm trying to install the YouCompleteMe extension to my vim setup, but it requires my vim to have the version of 7.3.584 or higher. The vim shipped with my Ubuntu 12.10 is 7.3.547, so I had to recompile vim from source following this instrucion.
As the instruction says, I executed:
sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev \ libgtk2.0-dev libatk1.0-dev libbonoboui2-dev \ libcairo2-dev libx11-dev libxpm-dev libxt-dev python-dev ruby-dev mercurial
which should give me all the packages needed for the compilation. However, when I've cloned the vim source and just about to start tweak the configuration for compilation, I got
... checking for tgetent in -lcurses... yes termcap library is not usable no terminal library found checking for tgetent()... configure: error: NOT FOUND! You need to install a terminal library; for example ncurses. Or specify the name of the library with --with-tlib.
I did some research, and got the general sense that I should specify ncurses as my terminal library. But when I did
it yells back
... checking --with-tlib argument... ncurses chekcing for linking with ncurses library... OK chekcing for tgetent()... configure: error: NOT FOUND! You need to install a terminal library; for example ncurses. Or specify the name of the library with --with-tlib.
I don't know if there is anything I've been missing, or if there is another way to get the newest version of vim? Many thanks!