Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wish to hide some windows icons from my desktop folder1, but cannot. When I click delete, it says they will be deleted from my desktop (which they already are), but they remain visible in the desktop folder, which is where I wish them removed. Is there any way I can remove these? (I always use Win+E which really lets me get to all of these easy enough).

Offending icons: Libraries, Homegroup, User folder, Computer, Network, Control Panel, and Recycle Bin. Example of desktop folder

For those who might be wondering why, I find myself in this folder a bit to often (including when uploading a file), and find these nothing but clutter, especially as these always default to the top.

Thanks for your help!

1 By desktop folder, I mean the folder you would see by going to "My Computer" and clicking "Desktop" on the top left under Favorites.


Note: Changing my "Desktop Icon Settings" under "Personalize" does not affect the desktop folder, but rather just the desktop view.

share|improve this question
    
Are you running on the admin account? If you're a normal user, this is most likely the issue. –  user88311 Apr 6 '13 at 17:44
    
@user88311 It says I am the administrator under User Accounts. The computer I am currently trying this on only has the one account. –  Fewfre Apr 6 '13 at 18:00
1  
@Psycogeek : these tweaks are about removing icons from desktop view not desktop folder in Windows Explorer, as explicitly stated in question... –  psycho Apr 16 '13 at 12:47
    
As mentioned, these are for the actual desktop view. I tried the one on sevenforums before coming here, with no success. –  Fewfre Apr 20 '13 at 1:18
    
Try the advice in the article Cannot delete icons, files or folders on Windows desktop and let us know. –  harrymc Apr 22 '13 at 8:03

5 Answers 5

up vote 4 down vote accepted

You can remove 3 of them by deleting some registry keys.

  • Open regedit.exe
  • Navigate to Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\
  • Remove the following folders corresponding to each icon:
    • Homegroup : {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} (default item has the value 'Other Users')
    • Network : {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} (default item has the value 'Computers and Devices')
    • Libraries : {031E4825-7B94-4dc3-B131-E946B44C8DD5} (default item has the value 'UserLibraries')

I have tested this on my PC and it worked. However, These icons will get removed from the Explorer navigation panel also.

Source

share|improve this answer
    
I have an addtional entry in one of those locations, the rest are deleted. 1) {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} STRING "Removal Message" DATA "@shell32.dll,-9047" . . 2) {450D8FBA-AD25-11D0-98A8-0800361B1103} STRING "Removal Message" DATA "@mydocs.dll,-900" . . Mabey this removal message is from Add/remove? –  Psycogeek Apr 22 '13 at 19:44
2  
Be warned, I have found that removing the above specified registry key for 'Network' can cause issues when attempting to browse to other computers using UNC names. See this thread. –  Fopedush Apr 22 '13 at 23:08
    
@Psycogeek: That refers to the message to be displayed when trying to delete the icon from explorer. See win7dll.info/mydocs_dll.html –  vahissan Apr 23 '13 at 13:35
    
A least for those 3 icons works like a charm. Thanks! –  Fewfre Apr 23 '13 at 23:14
    
@kyomu Did you continue searching that same location for any others? –  Psycogeek Apr 24 '13 at 22:05

The Desktop folder you're opening is a virtual folder. It doesn't surprise me that you can't delete these items.

If they annoy you so much, just remove the Desktop shortcut from the Favorites and place a new shortcut there, which points to %USERPROFILE%\Desktop. This one will only show your actual files on the Desktop.

There's something really interesting happening with that shortcut though. If I change the icon of that shortcut to the icon of the original Desktop shortcut, it will behave just like it.

In case this doesn't behave as expected, Bob pointed out that you could also create a new library and add your profile's desktop folder into it. Additionally, you could add the Desktop folder for all users (C:\Users\Public\Desktop).

This also has the benefit that you could include even more folders that contain a selection of shortcuts you might want to have as well (like the Network view).

share|improve this answer
1  
I have tried that, and it has the behavior of acting just like the original Desktop shortcut. –  Fewfre Apr 23 '13 at 13:34
    
@Kyomu: Does it make a difference if you use the actual path instead of %USERPROFILE%? I have tried this myself before posting the suggestion and it worked quite well. –  Oliver Salzburg Apr 23 '13 at 13:36
    
I went to C:\Users\UserName and then dragged the Desktop folder on the favorites (removing the original desktop shortcut first and once without). It seems even creating a normal shortcut to my user profile desktop does this. –  Fewfre Apr 23 '13 at 23:20
    
Additionally, even if this worked you'd be missing items from the "all users" desktop. Perhaps some sort of union filesystem? I'm not sure if that's possible in Windows. Hmm... perhaps a Library. –  Bob Apr 23 '13 at 23:41
    
@Kyomu: Weird. That's exactly the same way as I've created my shortcut. And I've just did it again just to confirm it :( –  Oliver Salzburg Apr 24 '13 at 9:31

The following worked for me on Windows 8 x64:

  1. Delete the Desktop shortcut from favorites.
  2. Add Desktop again to favorites. That shortcut will still show the unwanted icons.
  3. Rightclick the shortcut -> Properties -> Change icon.
  4. Select a different icon or the same, doesn't matter. Press Ok.
  5. Press Ok in the Properties dialog. The Desktop shortcut no longer shows the unwanted icons.

Interestingly, if you repeat steps 3-5 the shortcut will revert to its original behavior.

share|improve this answer

You should try revoking all access from your user profile(incase you are a admin user you may create another user)

Just go to C:\Users{Your profile}\

Right click the desktop folder, select properties and go to "security" tab

Remove the permission to read, they should become invisible.

See the photo

share|improve this answer

If the icons are removed (after deletion) from desktop view but they remain in Desktop folder visible from Explorer: 1. you can try to remove them from Public\Desktop folder (C:\Users\Public\Desktop), 2. or you won't be able to remove them from this folder - they are system icons (would need to edit registry but I don't guarantee success).

share|improve this answer
    
The only things in my Public\Desktop folder currently are a few shortcuts. –  Fewfre Apr 23 '13 at 23:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.