Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Normally, when an xfce app e.g. Thunar opens a file in an external program, it opens a new window on the current workspace to view that file. This is how I always want to open files and urls.

However, when I open a url in the terminal ("Open Link" in right click menu), it brings the browser window from another workspace to the current one and opens the url in a new tab. I tried to prevent this by setting "When a new window raises itself" to "Do nothing" in the Window Manager Tweaks, but now the url just opens in a new tab in an already open browser window without bringing it to the current desktop.

How can I get xfce to stop treating urls as a special case and just open them like a file path, in it's own window?

share|improve this question
    
What browser are you using? and in what OS? ... well os does not really matter xfce is all that same. – user213584 Apr 6 '13 at 21:09
    
Chromium, but the same thing happens when I change my default browser to Firefox in the Preferred Applications. – Dan Ross Apr 7 '13 at 1:40
    
In Mozilla. go to edit - preferences - tabs and un-check "Open new windows in a tab instead". Does this solve your problem? – user213584 Apr 8 '13 at 5:38
    
That works! If you put that as an answer, I will accept it. I thought it was xfce that was telling the browser to reuse windows. – Dan Ross Apr 8 '13 at 15:24
    
For Chromium, see this answer. – Dan Ross Apr 8 '13 at 15:30
up vote 1 down vote accepted

go to edit - preferences - tabs and un-check "Open new windows in a tab instead"

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .