Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Fedora 17 and ext2explore 2.2.71 worked as advertised. Since I installed Fedora 18, it no longer works. I already reinstall the program, but the program can't detect the partition. What alternatives do I have? ext2explore was the most recent program I could find

share|improve this question

migrated from stackoverflow.com Apr 7 '13 at 0:29

This question came from our site for professional and enthusiast programmers.

1  
So you made sure, that it your file system is still in a supported (=ext2/ext3/ext4/lvm) partition format? –  superuser0 Apr 7 '13 at 13:08
    
I did, it's ext4 like in Fedora 17. –  user1911149 Apr 7 '13 at 17:15
    
Alright. :) You might want to try other products that claim to be able to mount ext4, like ext2fsd.com, ext2read.blogspot.com or sourceforge.net/projects/ext4tc. –  superuser0 Apr 7 '13 at 17:22
    
Just tried all those without success. –  user1911149 Apr 7 '13 at 21:20

1 Answer 1

up vote 1 down vote accepted

Gotcha!

Using Disk Internals Linux Reader I can read my files again. It's a bit clunky, but it's enough to copy a file or two sometimes, I don't need more.

The "problem" is that Fedora 18 uses LVM by default, so ext2explore couldn't find the drive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.