Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This exact same question was asked here, but the OP was asking in regard to a Windows system. I am running Linux Mint 14 "Nadia" - KDE (64-bit). The answer @Kalyan Akella provided to that question should work for me, but it does not.

Here are the details of my situation:

  1. To stay consistent with my development team I need to use the 32 bit version of jdk-6u18, so I have downloaded jdk-6u18-linux-i586.bin.

  2. Before installing the JDK I have completely removed all (and I mean all) Java related packages, including all OpenJava packages. I have tried leaving java-common installed, but it doesn't make a difference.

  3. To install a Java 32 bit JDK on my 64 bit OS I had to install ia32-libs as suggested here.

  4. I have tried installing the previously mentioned JDK in the following directories...

    /usr/local  
    /usr/lib  
    /usr/java
    
  5. I set my JAVA_HOME variable accordingly depending on where I have installed the JDK at (i.e. the path to the jdk1.6.0_18 directory). I add $JAVA_HOME/bin to my path. I have also set the (unneeded?) JRE_HOME variable to $JAVA_HOME/jre.

    When I run set all variables display as I would expect them to. In the jdk1.6.0_18 directory I have also tried setting permissions recursively to 755 just to make sure my problem was not a permissions error. With all of these configurations everything Java related seems to work fine except the browser plugin.

  6. I have tried setting the MOZILLA_HOME variable to ~/.mozilla and $HOME/.mozilla. Both seem to accomplish the same thing and display as I would expect them to when I run set.

  7. I understand that Chrome, Chromium, and Firefox require a link to libnpjp2.so in a plugins directory for Java to work in those browsers. I have created the link using sudo ln -s in the following directories...

    ~/.mozilla/plugins
    /usr/lib/chromium-browser/plugins
    /usr/lib/firefox/plugins
    

    ... and have also attempted to set the permissions of the link to 755, all to no avail.

    I have run out of ideas, and I really don't want to have the dual Java installations. Any suggestions would be appreciated.

share|improve this question

migrated from stackoverflow.com Apr 7 '13 at 4:48

This question came from our site for professional and enthusiast programmers.

    
Don’t use Java 6.18. It is old, buggy, and insecure. If you absolutely must use Java 6, use the last vesrion (6.43). It is still old, buggy, insecure and unsupported, but at least not as much as the one you are trying to use. –  kinokijuf Apr 7 '13 at 5:07
    
Unfortunately it isn't that easy. My organization uses 6.18 so that is what I need to use as well. –  ubiquibacon Apr 7 '13 at 13:50
    
Java 6.43 is 100% compatible with 6.18. –  kinokijuf Apr 7 '13 at 20:08
    
@kinokijuf It isn't about compatibility, it is about matching development and production environments as exactly as possible, bugs and all. If 6.43 was exactly like 6.18 then there would not have been a need for 6.43 :-) –  ubiquibacon Apr 7 '13 at 20:28
    
You shouldn’t use 6.18 in a production environment. There are lots of exploits for it in the wild. –  kinokijuf Apr 9 '13 at 7:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.