Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have looked through what feels like every single forum and post that could exist about my problem and none of them are to my exact specifications. So here goes.

I spilled a sticky drink onto my computer. Not the whole drink got on the computer, but a lot did. I wiped and dried everything down because after I tried to turn it back on it only turned on for a split second and then turned off.

I figured out by self-diagnosis that it was the graphics card, poor thing. BTW, I have a gtx 560 ti (msi frozr ii). So I plugged everything back in and it started like a charm, BUT, there was no display. First thing I thought was either the card was fried, or it was ram, so I plugged into the onboard, integrated graphics slot VIA VGA, and still had no display, so I said RAM. I tried all my sticks of RAM, I have 4, none of them seemed bad, but what is weird is my computer turned on and stayed on just fine even if I took out all 4 sticks of ram,not only, but I also had no beeps. Still have had no beeps through this whole process.

Anyway, so I figured now it's either my graphics card is shorted out, although the fan turns on on the graphics card, and it gets hot, which tells me it's running, I just don't know if it's shorted or not. Or it's my CPU that is shorted, OR it's my motherboard!

I'm leaning towards the motherboard because my USB ports seemingly do not work neither does the on board graphics slot. Power supply works by the way, all my fans turn on (except for the one on the CPU itself) and all the lights on all of my fans turn on and all the lights on the outside of the case turn on.

Soooo. What is it guys? I'm decent with computers and have gotten myself this far, I thought I could not be beaten and would not have to get more parts but it seems I have lost. So please help me I do not know what to buy and I'd rather not buy it all, because I cannot afford it.

share|improve this question
    
didnt read everything but on my computer with a i7 3770k i cant see anything at post unless i have my gt640 plugged in - bios related - is your bios default settings? –  dashboard Apr 7 '13 at 6:35
    
Yes I have never changed anything in the bios. Besides even if it wasn't, I wouldn't be able to see anything to change it back to defaults. Idid take out the little quarter sized disc that has to do with the BIOS earlier, but I put it back in. –  Anthony Headrick Apr 7 '13 at 6:39
1  
so your bios is reset to defaults ? –  dashboard Apr 7 '13 at 6:43
    
Yes because taking out the disc auto-resets it to default. –  Anthony Headrick Apr 7 '13 at 6:43
    
Its all about knowing how to dry it again. 1.bp.blogspot.com/-8qw3JX6ZsTU/TspUo4HNZFI/AAAAAAAABIM/… and to be sure not to power it when it is damp. –  Psycogeek Apr 7 '13 at 7:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.