Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am attempting to install Django on a remote server. I have yum installed the following:

apache mod_wsgi Django mysql (python is already installed)

I have uploaded my project to the directory: /home/ec2-user

I am now on the step to point apache to the project and wsgi file. From the django site it explains that a virtual host entry must be created in the httpd.conf . I have added the following entry:

WSGIScriptAlias / /home/ec2-user/mysite/wsgi.py
WSGIPythonPath /home/ec2-user/mysite

<Directory /home/ec2-user/mysite>
<Files wsgi.py>
Order deny,allow
Allow from all
</Files>
</Directory>

When I hit the root of my site, I get the following error: You don't have permission to access / on this server.

If I change the user and group in httpd.conf to ec2-user which I believe is the owner of the wsgi file, I get the error: The requested URL / was not found on this server.

Am I missing a step or have I setup the virtual host incorrectly?

share|improve this question
    
This is a permissions problem; and possible solutions for it are listed in the apache wiki. Most probably you have SELinux enabled and you need to run chcon to fix it. This is not really programming related though. –  Burhan Khalid Apr 4 '13 at 4:01
    
Off-topic for SO; belongs on Super User –  Ex Umbris Apr 4 '13 at 4:51
add comment

migrated from stackoverflow.com Apr 7 '13 at 8:38

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.