Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just started getting a message that a USB device is not working properly. This is on a new Thinkpad T60 running Windows XP Professional SP3.

I have had all devices attached for about 10 days or so.

When I go to Device Manager there is no sign of a problem: everything is working correctly.

I am unable to find out which device it is.

I searched Super User, but the only reference I found was to older computers which may not be USB 2.0 capable. This is not my problem.

EDIT: I realized I had a harddrive attached but turned off. Although I could not track down any error messages except the balloon that came up, I have disconnected it and, so far, no messages. We'll see over the next day or two, but this may be the problem.

EDIT 2: This has not solved the problem. I get the message that one of the USB devices has malfunctioned and it points to "USB root hub (2 ports)" and shows an unused port and an unknown device. However, when I check my device manager, it says that there are no problems, everything is working as it should?

EDIT: I now found the event log view and there are two types of error messages. They do not relate to the time that I get the balloon. Two of the three are "Ati2mtag" errors and the third is "System Control Manager". Are these related to my problem, and the balloon just pops up randomly?

EDIT: well, I'm still having the problem, and have narrowed it down to a malfunctioning device.

share|improve this question
1  
any USB-related warnings or errors in the event logs? –  quack quixote Oct 20 '09 at 17:48
    
My "nothing" comment apparently was inaccurate. See edit above. –  Xavierjazz Oct 22 '09 at 3:18

4 Answers 4

Does the message keep coming up? Even after a reboot?

I would say check the event log (Start -> Right click My Computer -> Manage -> Event Viewer) and see if there's anything that looks suspicious. I've found http://eventid.net to be helpful to track down errors in the event log.

EDIT: I would try reinstalling your drivers, starting with your chipset and video.

share|improve this answer
    
Thanks. +1 for helping me find event viewer:) I checked everything there and there was no sign of any problem. –  Xavierjazz Oct 20 '09 at 18:08
    
Interesting. Does the message come up after a reboot? And your external usb drives, usb printers, etc. all work? –  emgee Oct 20 '09 at 20:29
    
Still coming up. See my edit. I have a usb microsoft mouse, a 150 usb Hard Drive and a microsoft wireless headphone/mic attached to the 3 usb outputs of my machine. –  Xavierjazz Oct 22 '09 at 3:17
    
I updated the answer. I think reinstall of drivers is in order -- looks like video and chipset. Could be random driver corruption -- it's Windows after all :) –  emgee Oct 22 '09 at 3:56
    
By Chip set do you mean the "APCI Multiprocessor PC"? –  Xavierjazz Oct 22 '09 at 4:53

See this USB Troubleshooter and also USB Troubleshooting Guide for Windows XP. These articles might give some idea how to track down the problem.

You should also resolve all errors in the Event Log, by installing drivers (preferably from the manufacturer's site) or other.

share|improve this answer
up vote 1 down vote accepted

I took my computer to my local tech. He updates the drivers. He said that it was because, although I am using a powered hub, I have so many devices hooked up that the power it supplies is inadequate. All still seems to be working but I still occasionally get the message.

Thanks all.

share|improve this answer

I had a similar problem on my X41 recently. I have a Bluetooth mouse and have used the USB ports to connect a GPS and the SD card slot to read a camera SD card. I had powered the laptop right down and back up thinking that would clear the USB problem - but it kept coming back intermittently.

The 'USB error" error message would pop up - sometimes 5 or 6 times in a row. I would close the pop-up window and continue working.

One day the PC turned off while on battery power and would not turn back on meaning pressing the power button did nothing. I thought it was toast. I tried removing the battery, putting in a known good battery - plugging in the power supply. Nothing would work. I googled the problem of thinkpad - no power on - and found a post talking about removing the power supply and battery then pressing the on/off button ten times and finally on the 11'th press - holding the power button down for 30 seconds. I thought - "yah right" - but gave it a try and it worked!

The Thinkpad came back up - and worked for about 3 hours - then powered down again - this time with the A/C plugged in. I re-did the 'power button 10 times routine - had to do it a couple of times. It came back up.

I cleaned out temp files on the disk, then ran a chkdsk with the 'check all sectors' setting. The laptop ran into the night doing that disk check - and come morning it was still on. Since then I have had no 'USB error' messages - and it has been running just fine.

So maybe try a complete disk chkdsk and see if that fixes anything.

share|improve this answer
    
@Roger - Good luck. –  Xavierjazz Dec 10 '09 at 4:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.