Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Windows 7 laptops (one Dell and other Toshiba). I have a shared folder on the toshiba-pc, and both are connected to a wireless router. When I copy a large folder from toshiba-pc to dell-pc, (from dell-pc accessed the network share on the toshiba-pc->right click the fodler->copy->paste to local C:\ drive), the transfer speed shown by the Windows ->Copying dialog is between 180 to 200 kb/s!

I can download files much faster (2 mb/s) from the internet to these laptops (so that proves wireless router does not have any issue).

So I believe some settings on these laptops should be incorrect (may be n/w card setting), but I couldn't find where exactly is that settings. Can someone help?

Note: I know I could use other ways to achieve faster files transfer, like for eg, installing a webserver or an ftp server, and then using those protocol for the transfer. But I'm trying to see how to make this fast with default windows network file copy

share|improve this question

migrated from stackoverflow.com Apr 7 '13 at 21:32

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Its difficult to say for sure but here are some of the reasons it might be running slow:

  • Rather than 1 computer downloading from the internet at 2mb/s you are having 2 computers using the same wireless channel to communicate this halves the possible speed straight away.
  • You need to know what speed both computers are connected to the router at, find which one has the lowest speed and halve it. That is that highest theoretical speed, not the actual throughput. On windows you can do this by hovering your mouse over the wireless connection icon, a tool tip should show up indicating the speed.
  • Windows file copy is horrid. I prefer Terracopy, but there are many options
  • If you are are using 802.11g wireless this is generally slower than 802.11n, make sure everything in the chain (router and both computers are n capable)
  • There are loads of other factors than can impact wireless speed.

To try improving the speed you could:

  • Check what channel your router is on, and use a tool like inSSIDer to see how congested that channel is in the area, move to another channel that is less congested (but note that there are only 3 non overlapping channels in 802.11g; 1, 6, 11)
  • Move the computers closer to the router, but note this likely wont help if you are a congested channel
  • If you are on 2.4ghz wireless, move to 5ghz if possible. It will be far less congested
  • If possible make sure your router is set to use 802.11n, and that both of your computers wireless cards are n capable and using it (they should use out of the box if they are n compatible)
  • Plug one of the computers into the router
  • Plug both of the computers into the router (this is the best option in terms of speed)

There are likely to be some more options as well, but this is all I can think of at the moment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.