Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm missing several options in catalyst control center, clicking detect displays causes CCC to hang. Under the information tab in control center under hardware it says, Device ID, Graphics Bus, Maximum Bus setting, memory size, memory type, core clock in mhz, memory clock in mhz are all "Not Available".

I get none of these problems in Windows Vista Ultimate 64bit/Windows 7 Pro 64bit/Windows 8 Pro 64bit. (Yes my particular build has experienced all these operating systems.)

I'm using 13.1 drivers, and I've tried the 12.x drivers.

This is a fresh install of Windows Server 2012

Specs:

Fx-8350

8GB G.Skill Sniper Memory

1TB WD Black

Asus M5A97 R2.0 (970 Chipset) motherboard

Diablotek 675W UL powersupply.

share|improve this question
    
have you tried running the CCC as root? –  dashboard Apr 8 '13 at 2:33
    
How would I do that? I think CCC is the problem myself. The install log shows the missing information. –  Sorceress Stabber Thomas Apr 8 '13 at 2:42
    
find the CCC.exe in your programs then right click and do "run as administrator" –  dashboard Apr 8 '13 at 2:45
    
Running as Administrator has done nothing. earlier I even even made sure to install by right clicking and choosing "Run as Administrator" –  Sorceress Stabber Thomas Apr 8 '13 at 2:48
    
This sounds like a pure driver problem. The solution would be to report it to AMD and hope its fixed. You really don't need CCC nor the AMD drivers the generic display drivers are good enough on Windows Server 20012. –  Ramhound Apr 8 '13 at 12:06

1 Answer 1

I would recommend removing the driver from the Device manager and be sure to select the "Delete the driver software for this device" option".

Then reboot in Safe Mode and re-install the driver there. Be sure to install the drive using "Run as Administrator". If this fails, reboot normally and install the driver from a normal boot using "Run as Administrator"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.