Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to make openssh work on android phone. When I'm trying to log in it refuses to accept my key. Here is the related lines of debug log:

debug1: attempt 1 failures 0
debug2: input_userauth_request: try method publickey
debug2: userauth_pubkey: disabled because of invalid user 

Strace shows that it doesn't even look for the .ssh/authorized_keys file. So the question is how to make root user valid.

I've created /etc/passwd with appropriate root user entry but it didn't help. I don't see any other related files reading in strace output for sshd.

share|improve this question

migrated from stackoverflow.com Apr 8 '13 at 3:10

This question came from our site for professional and enthusiast programmers.

    
I've set it to yes, didn't help. –  Equidamoid Apr 7 '13 at 18:32
    
AFAIK no, "move" is "take from here", "put there", usually somebody with enough reputation points will do it, but you can delete it as well, and ask there. I guess you reloaded sshd? I'm not really familiar with android, not sure how sshd is to be configured on it. –  Piotr Wadas Apr 7 '13 at 18:32
    
Googled it, you're right, will now wait for someone who can do that... Yes, I restarted it every time, all options related to keys are enabled/set. –  Equidamoid Apr 7 '13 at 18:40
    
Welcome to Super User. Please note that we have a site dedicated to Android: Android Enthusiasts If you would like us to move the question to that site (you might get better answers over there), please flag the question for moderator attention and ask for it to be moved :) –  Oliver Salzburg Apr 8 '13 at 14:28

1 Answer 1

Found it! It was incorrect /etc/passwd: root had wrong shell. Here is a line in strace output that showed it:

[pid 30439] stat64("/bin/sh", 0xbefb0f10) = -1 ENOENT (No such file or directory)

(Maybe this is not an answer...)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.