Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm doing a rebuild on my computer at home. I need to have both both Windows and Linux simultaneously, so I normally use Windows with Linux installed on Virtual Box. I downloaded and installed TOR in Linux but when I try to run TOR I get this in console:

livepassion@livepassion-VirtualBox:~$ tor
Apr 08 20:18:58.345 [notice] Tor v0.2.2.35 (git-73ff13ab3cc9570d). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux i686)
Apr 08 20:18:58.350 [notice] Initialized libevent version 2.0.16-stable using method epoll. Good.
Apr 08 20:18:58.350 [notice] Opening Socks listener on
Apr 08 20:18:58.350 [warn] Could not bind to Address already in use. Is Tor already running?
Apr 08 20:18:58.351 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Apr 08 20:18:58.351 [err] Reading config failed--see warnings above.

How do I make TOR work within virtualBox?

share|improve this question

migrated from Apr 8 '13 at 23:04

This question came from our site for professional and enthusiast programmers.

Ok, then test if you can get out to the Internet using ping, if there is no connectivity then there is a problem. Question, when you bridge, do you manually put in the new ip, or does virtual box do this? – user215405 Apr 9 '13 at 2:51

Ok the is a loop back address, your error message is reporting no connection, Meaning that a virtual network adaptor may not be installed, if the adaptor is installed then there is no bridged network connection.

Go to settings for that virtual machine and make sure that the virtual adaptor is bridged/ nat'ed.

Note: allot of this information is provided on the virtual box documentation, please read through as there is good information that could help you.

share|improve this answer
I have installed Bridged Adapter. Linux IP is: Windows IP is: – user2110927 Apr 8 '13 at 20:02

Note that the Virtual Box IP's will always be if you are using NAT mode. If you want a direct TOR IP to the VM you will need to put it in Bridged Mode which will emulate a real Ethernet card with a direct line.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.