Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use English Win7 with English Excel 2010, but Hungarian locale (we have decimal comma). Evey time I try to enter a fraction, it gets converted to a date. 5.6 becomes 2013.05.06, and 5,6 becomes 1900.01.05 14:24:00. How can I stop this behavior? I do not want to format the cells as numbers, because than I have to set the number of decimal places. Either my integers will have ,00 at the end, or my floats get truncated.

Why does it happen anyway? If I need a date, I enter a date. Do not convert anything! How can I turn this off, preferably for excel as a whole, not just for individual spreadsheets?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Put ' before your value in the cell

share|improve this answer

I don't have Excel 2010 but I expect that formatting cells as "Text" will do the trick.

share|improve this answer
    
If I format the whole sheet as text, the functions will not be evaluated. –  András Apr 9 '13 at 9:07
    
What I am looking for is most likely a checkbox in Options. Or at least is should be. –  András Apr 9 '13 at 9:10

I cannot reproduce your problem (even after I set my decimal separator to comma) but I have an answer for you to try.  What’s the greatest number of decimal digits that you will ever want to display?  Let’s say it is four.  Set a custom format on the cells where you will be entering numbers to #,####.  Now, if you type 5,6, it will be displayed as 5,6, and if you type 5,642, it will be displayed as 5,642.  At least that’s what it did on my machine (Excel 2007).  The only drawback that I encountered is that, when I typed 5, it was displayed as 5,.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.