Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Virtualbox instance running the latest Ubuntu hosted on OSX. Things worked fine until today when, for no apparent reason, Ubuntu stopped raising the network card on startup.

I've fiddled with all network options in VirtualBox but nothing seems to work.

How can I troubleshoot this?

Added as suggested:

I can see eth0, but it has no IP is assigned. Could the problem be with the router, to which I do not have access?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Does the host still have Internet connectivity? Then traceroute to somewhere outside of your network - Google, f/ex - and see where the failures begin.

Edit: Someone may be able suggest a debug path, but if you care more about getting the broken VM working than understanding why it doesn't, you can make a new VM, confirm it can communicate, then use its net settings to re-configure the currently broken VM.

share|improve this answer
    
Host is fine. The problem is that when ubuntu boots up fails to start the network cards. I can see eth0, but it has no IP assigned. –  Cocoaster Apr 9 '13 at 15:24
    
This would be useful to add to your question, along with anything else you've learned about the issue that might help someone help you. –  JRobert Apr 9 '13 at 15:34
add comment

If your OSX Host still has networking, and you don't see any IP address on the interface, I'd guess networking somehow got hosed on Ubuntu.

Could you run dhclient? see if that gives you an address.

share|improve this answer
add comment

I too had the exact same issue, Ubuntu client and OSX host. The problem was DHCP stopped working for an unknown reason. I had to switch to static IP assignment. Then I switched to Vmware Fusion.

share|improve this answer
    
I just installed a new image. Fixed everything. –  Cocoaster Apr 11 '13 at 15:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.