Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After some initial trouble, I was able to install Fedora 18, but Had to Disable Secure Boot, disable Fast Boot, and Enable CSM.

Side Note: I was reading that by Enableing CSM I was not going to be able to boot Windows 8, but the fact is that Windows 8 booted normally (before installing Fedora).

Below what I did.

Followed the normal installation process, booted Fedora DVD, when selecting the Partition Layout it complained about needing a 1MB BIOS Boot, so I created it and continued with the installation.

Now, After installing Fedora, nothing is booting, I just get the BIOS settings screen and the only boot option is the CD/DVD media.

I can boot Fedora Live CD and installed gparted. All the partitions are there, So I am sure Fedora installed correctly and I still have Windows partitions, but somehow the boot got messed up. I would need to maybe reinstall grub or something similar??

Below is a screen of gparted (using Fedora Live CD)

gparted

Any help with this is much appreciated.

share|improve this question

3 Answers 3

I recommend you go into the firmware and disable CSM/BIOS/legacy support -- but do not re-enable Secure Boot. With any luck, that will at least get Windows booting. From there, you can manually install an EFI-mode boot loader for Linux. Details depend on what you decide to use. One approach is:

  1. Install rEFInd from Windows, following the instructions on the rEFInd site.
  2. Install the ext4fs EFI driver that comes with rEFInd. (This involves copying one file; see the rEFInd documentation.)
  3. When you reboot into rEFInd, you should see one or more generic Linux icons, along with a Windows icon. Highlight one of the Linux icons and hit F2 or Insert twice. This should open a simple line editor.
  4. Add ro root=/dev/sda5 to the boot options and press Enter. Linux should boot.
  5. In Linux, run the mkrlconf.sh script that comes with rEFInd. This will generate a configuration file that will eliminate the need to add ro root=/dev/sda5 to your boot options every time you boot.

It's possible to do much the same thing with GRUB or ELILO, but the details differ.

share|improve this answer
    
Thank you for your answer...Before posting here. I disabled CSM and tried booting that way. Still nothing, went straight to BIOS Settings –  JGeZau Apr 10 '13 at 1:51

I had a similar issue and fixed it by:

  • Ensuring CSM/BIOS/legacy support was disabled in the firmware.
  • Using GParted to remove the bios_grub flag (in your case from sda7).
share|improve this answer
    
Thank you for your response. See my answer for more details. –  JGeZau May 3 '13 at 14:03
up vote 1 down vote accepted

I decided to start all over. Booted from Fedor 18 Live Desktop, installed gparted, erased the linux partitions, then created home, root and swap partitions. Then I proceeded with the normal installation process. Now when selecting the partitions layout I followed JA Watson guide, which he recommended to pick the existing Windows EFI partition and mount as mount point /boot/efi. I did not have to create a BIOS Boot partition as I had originally done.

I have Fast Boot enabled and UEFI enabled as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.