Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just reformatted my hard drive and installed Windows XP and now I'm getting this when I try to start it up:

Please select the operating system to start:

    Microsoft Windows XP Professional
    Microsoft Windows XP Professional

Use the up and down arrow keys to move the highlight to your choice.
Press ENTER to choose.





For troubleshooting and advanced startup options for Windows, press F8.

I don't know why it's doing that since I only installed it once. Short of just whipping the drive, again, is there a way to delete the second installation?

There's only one partition so it's not like I can delete one of those and leave it at that.

When I click on the second "Microsoft Windows XP Professional" line I get this:

Windows could not start because of a computer disk hardware
configuration problem.
Could not read from the selected boot disk.  Check boot path
and disk hardware.
Please check the Windows documentation about hardware disk
configuration and your hardware reference manuals for
additional information.

Any ideas? Thanks!

share|improve this question

2 Answers 2

up vote 4 down vote accepted

You can edit the boot.ini file as described by Microsoft here.

Your boot.ini is probably something like

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect

and you should remove that second line. Make a backup first!

share|improve this answer

You can edit the boot.ini to remove the second entry. Follow the following steps:

  1. boot the working Windows XP
  2. click Start
  3. click Run
  4. type sysdm.cpl
  5. click OK
  6. on the Advanced tab click Settings under Startup and Recovery
  7. under System Startup click Edit. This opens the file in Notepad ready for editing. (You should save a Backup before you edit it)

The file will look similar like that:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP Professional" /fastdetect 
  1. remove the Windows XP which does not work. If you are not sure, best rename it first!
  2. save the file
  3. restart the computer
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.