Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Problem:

I am trying to perform an unattended, silent uninstall of the CutePDF Writer 3.0, via command line. Every available source I have found points me to these two commands:

[32bit] "%ProgramFiles%\Acro Software\CutePDF Writer\uninscpw.exe" -s
[64bit] "%ProgramFiles(x86)%\Acro Software\CutePDF Writer\setup64.exe" /uninstall -s

Sample sources: source #1 (v3.0), source #2 (v2.8), source #3 (v2.8)

Yet this doesn't work for me. Every time I try I get a message box I must click:

This will remove CutePDF Writer from your system. Do you wish to continue?

I have tried it many times with both clear installs and multiple installs/reinstalls on VirtualBox on following systems:

  • Windows XP
  • Windows 7 32-bit
  • Windows 7 64-bit

The problem replicates every single time. I also tried other popular switches like /silent, /verysilent, /S, even the SUPRESSMSGBOX which was once said to be working with the older installer of Writer. Nothing worked.

I have filed an issue at CutePDF website, but it's free software and not their support priority.

The Question:

Since multiple sources point to this method, I am kind of lost. Could they all be wrong, or is something wrong with my environment? Perhaps it's locale-specific?

I'd be thankful for anyone to check if the same problem occurs on other machines, especially on Windows locale different than PL (1045).

Perhaps someone knows some better way to perform an unattended uninstall of this product?

share|improve this question
1  
Have you contacted their tech support (cutepdf.com/support/Request.asp). May just be a bug in their product. –  Brad Patton Apr 9 '13 at 20:29
    
Like I said above, I've filed the issue using exactly the form you've linked. It may take some time though, and I am also trying to confirm it is not locale-related. Once I've spent many days trying to convince Western Digital that the SmartWare update was faulty and they were all the time claiming everything works; eventually it came out that they were testing it on US locale only and it was the only locale unaffected by the bug :D –  Michał Sacharewicz Apr 9 '13 at 20:34
    
sorry I missed that. We also have a silent install option for a product we build but it's very easy for a developer to add a confirmation message and ignore that setting. My guess is it's a bug. –  Brad Patton Apr 9 '13 at 20:37

1 Answer 1

up vote 0 down vote accepted

The matter is solved. Unfortunately, Acro Software Inc. removed this feature. Purposefully.

I received a following response:

Hello M.

The current version does not support silent un-installation.

Regards,
CutePDF Support Team

...for which I asked if it is a planned behaviour, eg. they're planning to keep it that way, or will it be fixed in the next release? The response was short:

We may change that in our next version.

Regards, 
CutePDF Support Team

I have asked them then if they could be in any way more specific, yet...

Unfortunately, we don't have schedule yet.
You may acquire the license of our custom PDF writer which can be 
install/un-install silently.

Regards,
CutePDF Support Team

Time to get reacquainted with other, comparable products :)


An alternative deployment workaround available is to use AutoIT with the following script:

AutoIT3[_64].exe uninstall-cutepdf.au3 "<uninstaller_path>" "<uninstaller_parameters>"

(note the parentheses, they are important!)

If FileExists( $CmdLine[1] ) Then

    Run( """" & $CmdLine[1] & """ " & $CmdLine[2] )

    WinWait( "CutePDF Writer", "Do you wish to continue?", 10 )
    ControlClick( "CutePDF Writer", "Do you wish to continue?", 6 )

    WinWait( "CutePDF Writer", "CutePDF Writer has been removed", 30 )
    ControlClick( "CutePDF Writer", "CutePDF Writer has been removed", 2 )

EndIf

Note that when using Wpkg, Wpkg-GP or other software deployment system running as SYSTEM user during startup, you need to make sure the service runs in desktop-interactive mode, otherwise AutoIT won't work properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.