Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

No matter what their origin, if I copy/download a text file to my PC, polish characters are replaced by some weird ones. I've tried converting the files to different encodings, but it was not of much help. What's weird is that when I open the file on a different PC before copying it to mine, the file displays just fine. What can I do about it? I'm on Windows 7 32-bit;

share|improve this question
    
What kind of file? What software are you using create/view these files? –  daxlerod Apr 9 '13 at 21:25
add comment

2 Answers

I've found a solution. I had to change the default language for non-unicode programs to Polish in Control Panel->Region and Language->Administrative->Change System Locale. I have no clue why it would affect how files with set encoding are displayed in Notepad or as video subtitles, but it worked.

share|improve this answer
add comment

For ordinary .txt files, try explicitly setting an encoding when saving them (Unicode (UTF-16LE) or UTF-8 using notepad).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.