Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ran an upgrade recently that borked my whole setup(with catalyst drivers). It caused artifacts at login/desktop and then a hard lock. However, I'm not asking about those problems, what I want to know is, how do I boot without any X11 with the new systemd setup?

I run slim as my login manager(used to never use them for reasons like this) and run fluxbox.

So, I tried setting slim to auto-login, but would see the same problem on my desktop. Then, I disabled slim, with systemctl disable slim and it would boot into my desktop(doing all this from single user mode). I altered ~/.xinitrc and commented everything out, but still, it would end up at slim instead of a tty login prompt.

Even using the kernel parameter systemd.unit=multi-user.target, which is supposed to be run level 3, in the grub gave me the exact same boot sequence. I tried many other targets to no avail. And Google basically gave me nothing but what I've already tried.

Is there any sure-fire way of booting without X11 with systemd?

share|improve this question
3  
how did you get to a terminal ? what i would try doing is booting into a arch linux install cd and chrooting into your existing system then running the #systemctl disable slim –  dashboard Apr 9 '13 at 23:41
    
Did you remove the symlink to the default login? Try rm /etc/systemd/system/default.target and then symlink runlevel 3 target with: ln -sf /lib/systemd/system/multi-user.target /etc/systemd/system/default.target. No need to use what @dashboard said, since you can simply hit F1 - F7 to change TTY prompts to various consoles and save a headache. You can check the run-level with systemctl list-units --type=target if you feel so inclined. –  nerdwaller Apr 10 '13 at 0:01
    
@dashboard: I got to a terminal by trying to get to runlevel 3: linux [...] 3 which in the case of systemd, just forces me into single user mode. "root password or ctrl+d" kind of stuff. –  Mike Apr 10 '13 at 0:08
    
@nerdwaller: yes, by doing systemctl disable default.target it removes the symlink, so in /etc/systemd/system/ the only thing there was the symlink to multi-user. –  Mike Apr 10 '13 at 0:09
    
what happens when you do ctrl+f5 or f6 to get into a different tty? –  dashboard Apr 10 '13 at 3:34
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.