Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP Pavilion dv4t-1200 entertainment notebook, and recently upgraded it to Windows 8. The wireless card never worked on Windows 8 so I reformatted the HDD and did a fresh install of Windows 7. however now I can't enable the wireless card. This is the problem I originally had with Windows 8. I can see the wireless network adapter which is enabled but the softkey on the keyboard is orange (meaning WiFi is turned off). The problem is that pressing the softkey won't enable the WiFi. All drivers are up to date. Please help. This is driving me nuts!!!

share|improve this question
    
Is there a physical switch for the WiFi? Also did you actually get the original drivers from the HP site? Windows might not have ones that support the button. –  trpt4him Apr 10 '13 at 1:56
    
Do you need to use function + softkey to enable the wireless? –  cpt_fink Apr 11 '13 at 1:24
    
no, there is no physical switch and it should simply turn on by pressing the softkey. I did get all of the drivers from the official hp site. there is no function + softkey option... –  user215730 Apr 27 '13 at 18:34
add comment

3 Answers

Boot up a live distro of Linux, such as Ubuntu. Test to see if you can use the WiFi through it, if you can, return here, if you can't, go to the local parts shop.

share|improve this answer
    
it works through ubuntu... but it should work through windows as well –  user215730 Apr 27 '13 at 18:34
add comment
up vote 0 down vote accepted

I found a solution for anyone else out there with a similar problem. It was a bios issue. Simply go into the bios, and reset to default settings. Viola! the problem will be fixed and you will be able to enable wifi on your laptop again.

share|improve this answer
add comment

It's possible your wireless adapter is disabled on startup, because the helper program is not turned on. To check this, open the Start Menu, type msconfig and open the one result. Select the Normal startup radio button, click OK, then restart the computer. Hopefully this will force the wireless to turn on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.