Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My windows doesn't boot. Here is a screencast. https://plus.google.com/104553781986069868504/posts/ddRjsxuvtUi

Initial situation

For some special cause, I had two concurrent windows 7 installations and a version of ubuntu (grub boot broken).

How I broke my boot

My computer is configured to work with UEFI (I speak here with boot) so notice that's there is NOT a story about MBR (I think), there's more interesting things about MSR, GPT and EFI on the web...

I tried to install Ubuntu with deleting one of the two windows partitions. This broke everything because Ubuntu doesn't support EFI installation yet. I used the Linux Secure Boot livecd to repair the linux boot. It worked... But I needed to modify the windows loader part to have a fully work installation.

Here is a description of what I did: http://wiki.nekland.fr/index.php/Grub_2_efi

But as you can see on the video, my windows start partition seems to be buggy. I saw two windows and no one works.

(I have an image of my disk if it can help but I can't post it right now)

Thanks for help !

share|improve this question

migrated from stackoverflow.com Apr 10 '13 at 2:07

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 1 down vote accepted

Here is the solution for all my problems.

Remember facts :

My computer is using SecureBoot/UEFI/GPT.

  1. I installed Windows
  2. I installed Ubuntu (on another hdd)
  3. The boot was broken I restored it with boot-repair
  4. Ubuntu boot, not windows. Impossible to boot on Windows.

The solution : (and the why)

Ubuntu support secure boot only since the last release (the 13.04 version). When I installed it, Ubuntu made automatically a MBR partition. The part of mistery is how boot-repair came to make a boot with using "MBR for Ubuntu" and "EFI for windows" (which obviously didn't work).

So I :

  1. Removed Ubuntu (because it's more simple to re-install than upgrade to GPT format partition).
  2. Installed the new version of ubuntu
  3. Use again boot-repair, which work pretty good this time

If you want to use Ubuntu LTS (no support for secureboot) or another distribution, you have to disable the "secureboot" option from your bios and be sure the partition your distribution create is in "GPT" format.

Hope to be usefull !

share|improve this answer
  • You should try to repair Windows 7 booting using Windows 7 installation/repair CD/DVD. Try automatic repair option (should be run up to 3 times with rebooting after each run). If errors persist just run following command:

bcdboot c:\windows - where c: maps to Windows 7 installation drive.

  • Then run Boot Repair for Linux. It should pick up Windows 7.

An UEFI capable BCD Editor can be downloaded here.

share|improve this answer
    
Thank you very much (you're amazing). But it didn't work. First I had to use diskpart with the "assign" command (who worked), then I did your command. The only positive result is that now, I can see the Windows installation when I try to repair it. But at start I'm still getting this: is.gd/VF3jys (photo of the error). The reparation (obviously) didn't work. –  Nek Apr 10 '13 at 23:02
    
I re-install my windows. I think your solution work... With a DVD not broken... –  Nek Apr 12 '13 at 9:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.