Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having the following problem: I have a ubuntu 12.04 lts machine and a network printer. The network printer is correctly configured in ubuntu, so I can print from my ubuntu machine. Furthermore I have a Windows 7 Home Premium Laptop. And I want to print with the exactly same network printer from this Laptop. So I looked into the configuration of the printer under ubuntu, and noted his ip-adress. It has the form: socket://xxx.xx.xxx.xxx:9100. Then I wanted to add a new printer in Windows. The first thing which is strange is, that windows detects every printer in our network (round about 15 printers), except the one which I need. So I clicked on (loosely translated) The wanted printer is not listed -> and then on add printer by tcp/ip-address or hostname. Next I pasted the complete ip-address (socket://xxx.xx.xxx.xxx:9100) into the field for the hostname. Windows is then searching for the device, but it can't find it. I also tried to paste the ip-address without socket (xxx.xx.xxx.xxx:9100), but no luck either. So I have several questions:

  • which ip-address should I provide to windows?
  • is it possible to copy the printer configuration, so that windows can read it from a file?

Next thing I tried was to set up a cups server on ubuntu, but this one doesn't detect the printer I need neither. So a question concerning this is:

  • Can I add a printer to the cups server, from a local configuration?

I hope I made my intention clearly visable: I have a network printer which works with my ubuntu machine, and I want to print from my windows laptop to exactly this printer. And the barrier is, that the printer is neither detected by windows 7, nor by cups on ubuntu 12.04.

Any help appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

IP Address would be xxx.xx.xxx.xxx without the :9100 (port). Is your ubuntu machine firewall switched on. Have you tried https://help.ubuntu.com/community/NetworkPrintingWithUbuntu

share|improve this answer
    
sometimes it is that simple! Thank you so much! (Solution was to omit the port) –  Rico-E Apr 10 '13 at 10:48
    
Please accept answer if it helped. Thanks –  Ali Apr 10 '13 at 11:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.