Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a strange problem. My icons seem to disappear randomly on my Windows 7. They were there a while back, now they ain't.

It happens often and quite randomly. Anyone know a fix?

enter image description here

share|improve this question
Are you sure the path to the executable is still valid? – Ryan Oct 20 '09 at 23:16
Yes, quite sure. – Grumpy ol' bear Oct 21 '09 at 6:07
Yet another solution, easiest one yeT: – Grumpy ol' bear May 7 at 19:52
up vote 15 down vote accepted

I figured it out. Here's the answer:

  1. Run "regedit"
  2. Go to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer
  3. Change "Max Cached Icons" to 10000 or more. Upper and Lowercase SENSITIVE!
  4. If it doesn't exist create it as new "string"
  5. Reboot

After that

  1. Go to "C:\Users\[Username]\AppData\Local"
  2. Delete IconCache.db
  3. Reboot again

Or try this solution that always works for me:

open cmd-console in admin mode
taskkill /IM explorer.exe /F
CD /d %userprofile%\AppData\Local
DEL IconCache.db /a
start explorer.exe via taskmanager

Edit 2016-05-07: Easiest solution: Link

share|improve this answer
@NoCanDO: YesWeCan! – Ivo Flipse Mar 12 '10 at 7:35
Oh, it doesn't work for me. – ablmf Aug 20 '10 at 21:27
I have found that if you try to delete the IconCache.db file while explorer.exe is running, the icon cache will not be rebuilt. You need to open a command prompt, kill explorer.exe with task manager, delete the icon cache file and then start explorer.exe with the task manager. – user13141 Aug 24 '10 at 13:44
The link worked for me. – saj Jun 16 at 8:06

I found the cause of the misteriously disappearing Windows 7 desktop icons and the reason why Show desktop icons now and then gets unchecked.

It’s INFRARECORDER !! Try for yourselves, when you start Infrarecorder and close it again, go have a look at “Show desktop icons”, it is unchecked (but the icons are still there). Check it on again and start Infrarecorder…. it is unchecked again.

This Windows 7 “bug” is irritating me since the beginning and now I found the cause: It’s Infrarecorder which is causing this problem.

Test it, please let me know and spread the news :-)

share|improve this answer
:From Anders: I would never have figured it out since I very seldom use Infrarecorder:) It seems people are aware at the forum: – KronoS Feb 25 '11 at 23:45
:From Rogier: In My case it was infra recorder as well. Very strange behaviour. (Also not too happy with the program itself, so its bye bye to IR) – KronoS Feb 25 '11 at 23:47

Assuming that the paths are still valid, try right clicking on the shortcuts and go to the "shortcut" tab. Click on the change icon button, and see if the icon you want is in the list (if there is any list at all).

I don't know why Windows is losing track of the icon (It's happened to me a few times), but hopefully this will provide a workaround.

share|improve this answer
I did. Doesn't help at all. – Grumpy ol' bear Oct 21 '09 at 6:08

It could also be that your C:\Windows\Installer folder is empty. In this folder Office or Windows Live software installs its icons and stuff...

When this is the case, you can try to copy the {...}-folders (with some kind of identity) to your own machine.

Edit: Added a link to a forum-post:

share|improve this answer

Microsoft Fix It service solves this problem without any editing work. Get it from here. It worked well for me. This service finds the problems and troubleshoots them.

share|improve this answer

You can easily bring all the icons on the desktop as described in the following:

Yes, it is tru, it is an InfraRecorder that makes them disappear.

share|improve this answer
Answers should be more than just a link. – David Richerby Oct 1 '15 at 7:06

I'm on Windows 7 Professional, and have been struggling with this frustrating problem for a while now. I have tried the solution recommended here, and increasing the max cached icons seemed to fix it for a while, then the problem came back.

I finally mentioned it to my co-workers, and one of them said I should check my Windows PATH, and shorten it if it's very long. It turns out the system PATH was over 2500 bytes in length! I removed a lot of cruft and brought it down to about 1k in size, and voila! The problem has not appeared since.

share|improve this answer

You must log in to answer this question.

protected by random Feb 25 '11 at 23:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .