Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with IPv6 connectivity. I have searched a lot of web sites, but I cannot find a solution.

Here is the ping output:

Ping ipv6.l.google.com [2404:6800:4005:c00::67] (with 32 bytes of data):
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=5ms
        ︙
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=672ms
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=5ms
Reply from 2404:6800:4005:c00::67: time=5ms
        ︙

Here is the tracert output:

ipv6.l.google.com [2404:6800:4005:c00::68] 
  1   372 ms     4 ms     2 ms  6to4.hkg1.he.net [2001:470:0:163::2] 
  2     4 ms     2 ms     2 ms  2001:470:0:163::1
  3     4 ms     4 ms     4 ms  google3-10G.hkix.net [2001:7fa:0:1::ca28:a10a] 
  4     4 ms     4 ms     8 ms  2001:4860::1:0:16 
  5     5 ms     6 ms     4 ms  2001:4860::2:0:119c 
  6     *        *        *     Time out
  7    12 ms     5 ms     4 ms  2404:6800:4005:c00::68 

My ISP provides IPv6 connectivity but I cannot connect. I am using IE10 and Windows 7.

share|improve this question
4  
Your first hop in the traceroute is a Hurricane Electric 6to4 relay, which shows that you are not using IPv6 connectivity provided by your ISP but that you are using 6to4. 6to4 has lots of reliability problems. I am a big IPv6 fan, but if the choice is between 6to4 and no IPv6 then I would strongly prefer no IPv6. Or go to tunnelbroker.net for a reliable IPv6 tunnel :-) –  Sander Steffann Apr 10 '13 at 18:22

1 Answer 1

If your ISP is providing you native IPv6, you definitely should not be going over 6to4, as your traceroute shows.

To resolve the issue, disable 6to4 (and Teredo for good measure, just in case). This will allow your native IPv6, if it is actually being provided to you, to be used.

On Windows Vista and higher:

netsh interface ipv6 6to4 set state disabled
netsh interface teredo set state disabled

If you have XP, use:

netsh interface ipv6 6to4 set state disabled
netsh interface ipv6 set teredo disabled
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.