Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought another headset, as my other ones were creating a lot of static noise. I used to have 3 headsets which worked fine in the past, but cause a lot of static noise now, they were all direct line headphones, and my friend suggested I get a USB microphone. He tested his USB headset on my PC and there was no beeping.

But I just bought a new headset, tried it on my PC, and it has a very loud annoying beeping noise, constantly when I speak, everyone on teamspeak can hear it, and I can hear when recording. However, when I plug the same headset into my laptop, it has no beeping noise, but has background noise instead.

I have tried plugging it into all 6 USB ports on my PC, but none of them solve the problem. I've tried editing some settings within the recording device options, but nothing works.

I do not know the name of the headset itself, however, here is the link to headset I bought off Ebay: http://www.ebay.co.uk/itm/USB-2-0-Stereo-Headset-Headphone-w-Mic-Laptop-Computer-PC-MSN-SKYPE-Games-VoIP-/140824992042?pt=UK_Headsets&hash=item20c9d2d92a

Any suggestions would be greatly appreciated thanks.

share|improve this question
    
You might be referring to audio feedback. – Arjan Jan 3 '15 at 17:08
  • Go to Control Panel\All Control Panel Items\Speech Recognition
  • Choose Set up microphone
  • Choose the type of your microphone
  • Try to make as loud noise as possible

So your microphone noise will be reduced

share|improve this answer

I have the exact same problems with this headset.

I have found that the beeping isn't as loud when you set the format to 44100Hz but does change to an even more annoying irregular beep/screech. Other than that I have not found a complete fix. I'm fairly sure it has nothing to do with feedback just the quality of the mic itself. I suggest to simply get a new, better quality headset.

  • Edit -

If you have specific KB_MS_USB ports, plug the Headset into one of those and set it to 48000 Hz. So far, no more beeping. Hope this can help

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .