Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to transition to tmux (version 1.6) on OS X 10.7 (so I'm sure I am making a noob mistake) and having problems with the simplest of commands. In my ~/.tmux.conf I have to map the prefix to Ctrl-a rather than :

set -g prefix C-a

but when I:

Wed Apr 10$ source ~/.tmux.conf                                                       │                                                                                      
-bash: set: -g: invalid option                                                        │                                                                                      
set: usage: set [--abefhkmnptuvxBCHP] [-o option] [arg ...]                           │                                                                                      
Wed Apr 10$ 

I get the invalid option error. Is this just a syntax issue or might there be some other conifguration issue? How would I fix this?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

tmux.conf is the configuration file for tmux. You are not supposed to source it within your shell, but rather tell tmux to source it.

Either of the following should work:

  • run tmux source ~/.tmux.conf

  • run tmux set -g prefix C-a

  • press the old prefix (CtrlB), :source ~/.tmux.conf

  • press the old prefix (CtrlB), :set -g prefix C-a

share|improve this answer
    
Wow, thx for answer - was starting to get really frustrated! –  timpone Apr 10 '13 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.