Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Western Digital 500 GB hard disk which I bought about a year ago. It has apparently stopped working since a while ago. The disk contains some very important data which I do not want to lose. I would be very grateful if you can help me recover the data from the disk and if possible make the disk usable again. Thanks.

Here is some information which might help you help me with this problem:

  1. When I connect this disk to my Macbook Pro, nothing happens. But when I unplug it, it shows the following error message:

    enter image description here

  2. I have set up a Linux-Windows dual boot on my desktop machine. When I try to mount this disk in Dolphin, the file manager I am using in Linux, it shows the following error message:

    enter image description here

  3. Windows says nothing when I connect the disk, but when I remove it, it says that the drive will have to be formatted before use.

    enter image description here

  4. Before the disk started behaving this way, I had connected it to my TV to watch a video, but the TV could not recognize the disk.

share|improve this question
    
Look out to this link. May be the TV formatted your hard drive on first connection? goo.gl/JBLe3 –  ivorykoder Apr 11 '13 at 15:35
add comment

1 Answer

I would try to mount it as root in linux, save all the data to another hard drive and format it.

share|improve this answer
    
I tried that and received an error similar to what NTFS-3g gives on OS X. –  missingfaktor Apr 13 '13 at 13:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.