Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'll list my symptoms...

  1. Running Windows 7 RTM 32-bit.
  2. I can't log in as a non-admin user, failure to connect to the System Event Notification Service
  3. If I log in as an admin user, I can't run anything as administrator (error: The system could not find the environment option that was entered), so I can't get into the Event Viewer, or run setup.exe off the Win7 disk, list the services, etc.
  4. If I run "sfc /scannow" everything reports normal.
  5. If I boot to "Repair my computer", the System Repair reports everything normal.
  6. If I boot to "Repair my computer", and go to the Command Prompt, "netsh winsock reset" reports "The system cannot find the file specified"
  7. If I boot to "Repair my computer", and go to the Command Prompt, I can't run setup.exe off the Win7 disk, because I'm in Safe Mode.
  8. I'm running out of ideas, short of installing the OS again. I'd prefer to Upgrade/Fix the installation I have, rather than installing a clean copy, but I can't do that without fixing point 3.

All the web pages I can find about this error describe solutions that involve running processes as administrator, but I can't do that (see point 3 above).

share|improve this question
up vote 1 down vote accepted

I've made some progress in this.

In Safe Mode's command prompt, I've disabled UAC.

reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f

Now I can run setup.exe off the Win7 setup disk as admin, and should be able to repair (by doing an "upgrade") my installation.

Having disabled UAC, I still couldn't get into the Computer Management window, it failed with an "Unspecified Error". I managed to run mmc.exe and attach compmgmt.msc, but I still couldn't into the Event Viewer, because the service wasn't running (and wouldn't start when I tried).

So now I'm going to do an "upgrade" and see how that goes.

share|improve this answer
The upgrade worked nicely, and everything's fixed now. – Rob Farley Oct 22 '09 at 22:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.