Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ssh into a remote machine with root which is installed with Fedora 18. I typed in

ifconfig

but I got

ifconfig: command not found

and also

     [root@kitch proxy]# /sbin/ifconfig
     -bash: /sbin/ifconfig: No such file or directory
    [root@kitch proxy]# sudo yum provides ifconfig
    fedora/filelists_db                                                                                                          |  25 MB  00:00:04
    updates/filelists_db                                                                                                         |  12 MB  00:00:02
    net-tools-2.0-0.2.20121106git.fc18.x86_64 : Basic networking tools
    Repo        : fedora
    Matched from:
    Filename    : /sbin/ifconfig

then I typed in ip link show

        [root@kitch proxy]# ip link show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
        link/ether 00:1a:a0:23:86:6c brd ff:ff:ff:ff:ff:ff

and ip addr show

    t@kitch proxy]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
        link/ether 00:1a:a0:23:86:6c brd ff:ff:ff:ff:ff:ff
        inet 138.96.116.9/21 brd 138.96.119.255 scope global em1
        inet6 fe80::21a:a0ff:fe23:866c/64 scope link
           valid_lft forever preferred_lft forever

and

    [root@kitch proxy]# /sbin/iptables
    iptables v1.4.16.2: no command specified
    Try `iptables -h' or 'iptables --help' for more information.

there is no eth0 and the results are strange to me. Can anyone explain a bit?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Both Fedora and RedHat identify NICs that are embedded on the motherboard by emN instead of ethN.

EDIT: If you want to prevent uvdev from renaming eth0 to em1 check this:

http://comments.gmane.org/gmane.linux.redhat.fedora.general/421412

share|improve this answer
    
but on many other fedora machines, they are ethN, why? besides, why ifconfig doesn't work? –  misteryes Apr 11 '13 at 14:34
    
The other machines, do they have embedded NICs? I'm not a Fedora user but try: sudo yum provides ifconfig In order to know which package installs ifconfig and install it. –  jmdana Apr 11 '13 at 14:35
    
I tried, and updated the result, how to install? –  misteryes Apr 11 '13 at 14:39
    
yum install net-tools I guess... –  jmdana Apr 11 '13 at 14:41
    
@misteryes, it used to be called ethX until a short time back. The idea is to have stable device names (if you had e.g. two eth, which one was called eth0 depended on the random(ish) order in which they finished initialization). It will be called em0, the next one em1, always, even if it breaks etc. –  vonbrand Apr 11 '13 at 17:17

ifconfig on Red Hat-esque boxes often lives in /sbin, which often isn't in the default path; try /sbin/ifconfig and see what you get.

The manual page for ip is a good place to start finding out about its options, behavior, output, &c.

share|improve this answer
    
there is no iptables and /sin/ifconfig doesn't work –  misteryes Apr 11 '13 at 14:26
1  
The ip command is slated to replace ifconfig, but way too many fingers know ifconfig to be able to delete it just now... –  vonbrand Apr 11 '13 at 17:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.