Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I will explain things as well as I can, but even after a bunch of reading, I am still not too up on UEFI. I generally deal with high level software.

So I have a preinstalled Windows 8 system that would boot in UEFI mode with secure boot. I needed to also install Ubuntu 12.10 and I did so. To boot in Windows, I would set secure boot on. To boot in Ubuntu, I would set secure boot disabled. In either case, I used UEFI mode.

Later, when playing with Ubuntu, I was working with petitions and I messed it up such that the hidden recovery partition was gone and Windows would no longer boot.

I recovered with Windows 8 Enterprise Evaluation which I burned to a DVD. To install, I changed to CSM mode (BIOS legacy) and installed it just fine. After install, I could boot from the new OS in CSM mode. If I try to change to UEFI mode, the computer says no bootable media is present. When I then change back to CSM Mode, I get some blue screen with winlogin.exe error and I can't boot and my Windows 8 Enterprise is not directly accessible. I then put in a WinXP recovery disk, do automatic repair, and it fixes whatever issue was causing CSM Mode to fail, allowing me to boot from Windows 8 Enterprise Mode again. So I am left with a Windows 8 OS that will expire later this year, not the Windows 8 that came with my system.

Now, I have a recovery USB for my original Windows 8 OS which came preinstalled with the computer. Supposedly, it is a UEFI bootable USB. When I boot from CSM Mode, the USB is recognized but after a minute I get BIOS is not UEFI. When I boot from UEFI Mode, the USB is not recognized at all and I get the familiar no bootable media message present.

I reflashed the original BIOS with flashit and nothing bad happened but nothing improved either.

So how to I regain that UEFI boot capability? It doesn't seem I can boot anything in UEFI mode any more

share|improve this question
Can you get into your BIOS? – music2myear Apr 11 '13 at 16:20
@music2myear I can press F2 to get into the boot settings to change them to whatever I need them to be. Right now, I have CSM Mode setup which boots up the Windows 8 Enterprise Evaluation because I need my computer to do stuff while I am trying to resolve this issue. – demongolem Apr 11 '13 at 16:22
Can you get into your BIOS though. Getting to a list of bootable devices is not quite the same. What model computer do you have, or is this a Frankenstein, in which case, which motherboard do you have? – music2myear Apr 11 '13 at 16:26
Sorry, my loose use of terminology. F12 is the list of bootable devices. F2 is the BIOS setup. I have a Toshiba Satellite S855-s5379. – demongolem Apr 11 '13 at 16:40
If you insert the recovery USB and then power on, what bootable devices show up under UEFI settings? Also, have you tried asking Toshiba support or posted on their form asking how to use the recovery USB? – Karan Apr 11 '13 at 17:22
up vote 4 down vote accepted

After trying 20 different things, I finally solved the problem. I really think the downvote should be cancelled out because it was a perfectly answerable question.

To recap, I managed to wipe out both my Windows 8 partition and my hidden recovery from my hard drive leaving me no trace of the original OS that I had bought. So without question, I needed a recovery disk.

The recovery disk I received was not recognized under UEFI mode but was recognized under CSM mode. The reason for this, the fine people at Toshiba gave me a 16 GB bootable USB with all the necessary recovery files, but did not make it a UEFI boot disk. Oops ...

So I copied the files from the recovery USB they gave me to desktop. Made an iso out of those files on the desktop. Then with a fresh 16 GB USB, I made a proper UEFI boot USB and transferred the iso to it.

With a proper UEFI boot USB, I selected UEFI MODE and secure boot in the BIOS Setup and I was able to recover my original Windows 8 OS and Toshiba settings.

share|improve this answer

You can just leave the bios with all default setting:

  • uefi ON
  • secure boot ON

create a usb uefi boot with rufus program at the rufus website have the info how to created, then you have a clean windows 7 / 8 / 8.1 install & all drivers will work as is supposed to do,

also you can install linux on UEFI setting do the same but with linux.iso them in windows 8 download & open easyBCD to create the path to dual boot.

After all this make a small pertition with 6 gb minimum & create your restore partition formatting using the same method GPT UEFI with rufus.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.